0
$\begingroup$

I'm trying to render a glass bottle on a transparent background. There is lighting set up, and you can see the glass when you render it on a background, but when you omit the background from showing up in the render, it comes out black.

How do I make it so the glass shows up normal and not black without a background?

$\endgroup$
0
$\begingroup$

Make sure you have enough light sources in the scene.

Check Transmission bounces. The value has to be higher than 0.

Enable Transparent Glass.

enter image description here

$\endgroup$
  • $\begingroup$ Appreciate the fast response. I think I got it, though using the principled BSDF did not give me the same results. I was using 2.79b on a mac, I had to download 2.8 in order to see that transparent glass option, and the UI looks totally different. What version are you using because the setup looks like the old way and I'd prefer that! $\endgroup$ – cndyboom Nov 4 '18 at 1:01
  • $\begingroup$ Yeah, 2.8 UI gives me headaches. 2.79 build downloaded from here should have transparent glass option builder.blender.org/download $\endgroup$ – mikez Nov 4 '18 at 2:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.