2
$\begingroup$

When I click Numpad 0, The view port normally goes to the camera's perspective

In this picture you can clearly see where the camera is enter image description here

but when I click Numpad 0 to go to the camera's perspective it goes to the center of the skeleton for my model enter image description here

If anyone has a way to fix this, that would be greatly appreciated.

$\endgroup$
2
  • $\begingroup$ Check your input preferences for View Numpad. Maybe you changed it sometime? $\endgroup$
    – Valentin
    Commented Nov 2, 2018 at 14:19
  • $\begingroup$ In case anyone else encounters this problem, well, there is a bug i think that makes an armature become the camera. Removing the armature and appending it back from a backup file will stop the issue from happening. $\endgroup$
    – Ghost
    Commented Feb 8, 2022 at 9:04

2 Answers 2

3
$\begingroup$

Your camera is not active anymore, select it and press ctrl 0, or in the Properties panel > Scene > Camera > choose the camera you want.

$\endgroup$
1
  • $\begingroup$ If this is the right answer you should mark it as “right” with the green check mark. $\endgroup$
    – Valentin
    Commented Nov 5, 2018 at 8:23
0
$\begingroup$

The camera in my setting was active but had the same problem. The solution was to move the camera from a nested collection to the "Scene Collection"

enter image description here

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .