1
$\begingroup$

I'm creating new file by reloading Blender Start-Up file (Ctrl+ N) moving default cube a little higher, then apply Object > Quick Effect > Quick Smoke. I can start simulation and see smoke generating, I can also see smoke using Blender Render, but when i change renderer to Cycles this happens:

smoke domain in cycles

What may be interesting is that in Blender 2.8 alpha I can see smoke in Cycles (But there's lots of bugs). Maybe I have to do something with domain material nodes but I just started learning Cycles and I'm really don't know how to fix it, please help.

$\endgroup$
2
$\begingroup$

The Quick Smoke option automatically generates the smoke material based on your currently selected Render Engine. The Blender Render renderer uses different materials to Cycles and they are not interchangeable. Therefore, if you do 'Quick Smoke' whilst Blender Render is selected and then swap to Cycles, you will not have a valid material (since it will be the Blender Render material, rather than Cycles) and you will see the Cycles material rendered as the default (Diffuse) material.

The solution is to select Cycles renderer before you select Quick Smoke. The easiest way to resolve this will be to delete your Smoke Domain, select your Cube again, and then re-select Quick Smoke - this should create a new domain with the correct smoke material.

$\endgroup$
  • $\begingroup$ Thank you, it works with Cycles! But not with Eevee, do you know if there is any simple way to get default smoke materials for Eevee renderer? $\endgroup$ – Jarosław Chajneta Oct 31 '18 at 13:27
  • $\begingroup$ @JarosławChajneta Glad to help. I'm afraid I don't have much experience of Eevee - to be honest, I don't even know if Eevee supports volumetrics. As Blender 2.8 is still in development I'd suggest sticking with Cycles for now. $\endgroup$ – Rich Sedman Oct 31 '18 at 13:40
  • $\begingroup$ @JarosławChajneta I've just had a bit of a play around with Eevee volumetrics - it does, indeed, support volumetrics, but is disabled by default. To enable volumetrics you need to enable the Volumetrics section in the Render properties panel - this also allows you to configure the various volumetrics parameters. $\endgroup$ – Rich Sedman Oct 31 '18 at 14:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.