0
$\begingroup$

I've done a lot of research into the problem, but I'm a blender noob. I have

Removed Doubles Recalculated Normals Removed All Vertex Groups Removed Subsurface Modifier Added the Decimate Planar Modifier Ensured The root is where it needs to be Ensured Positioning for the Mesh and Bones are all set to Zero and Scale to 1

I tried to upload the blend file to Blend Stack exchange but its 80Mb and the max is 30, so I put it on drop box. Thanks for anything you can do to help.

https://www.dropbox.com/s/22gaww9l0w47sgo/Chaplain1.blend?dl=0

:Edit I uploaded the backup file, the new file is at the right point, sorry and thanks again.

$\endgroup$
1
$\begingroup$

In your file I founded 30.000 doubles and I applied the decimate modifier. The existing problem of bone heat weighting failed still exist, and is probably due to the overlapping geometry, which automatic weighting doesn't like.

I think you will have to split the character into various spare parts (in edit mode select one vertex, Ctrl L to select linked, P to separate).

This is a good practice also to optimize the animation performances: objects like skulls or some parts of the armor should not deform, they should only solidly follow a bone instead. Parenting an object to a bone (bone option after Ctrl P) is also lighter to calculate for Blender, so you will have less lag during animation process. I think you will have also to retopologize the sections that actually need to deform in the classical way, because the geometry is very bad and it will lead to ugly deformations. It's a long run, good luck (or start with a simpler character :)).

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.