0
$\begingroup$

I just started using Blender.

I'm trying to roll a ball running down a long pipe. Just letting the soft body physics run drops down the fps in solid view mode under 1 fps , which causes the animation player to stop.

My guess is that the objects("pipeline") its collapsing with is just to big?! But shouldn't this somehow be an easy job to do?

$\endgroup$
  • $\begingroup$ You need to bake the softbody calculations (cache section in the softbody settings). Without a bake blender is trying to calculate everything on the fly in real time, hence the drop to 1fps. $\endgroup$ – David Oct 28 '18 at 20:41
1
$\begingroup$

In your case (base along pipeline) the rigid body system is better suited to do the simulation, since it isn't imperative for the ball to deform.

Nevertheless creating a simpler collision geometry is helpful.

  1. Remove the current softbody and collision settings.
  2. Duplicate the track object. This track_duplicate will be used to create a collision object with less resolution. Remove the wireframe modifier of the track_duplicate and decimate it with a decimate modifier. (I first used the planar option, applied it the used it with the collapse option and applied it again.)
  3. Make the track_duplicate a passive rigid body object and set its shape to mesh.
  4. Make the ball an active rigid body.
  5. Hide the track_duplicate object (it will still be used for collisions) and show the original highres mesh.

ball along decimated track

You only need softbody object if they're supposed to deform.

$\endgroup$
  • $\begingroup$ i know i should thank you... anyway thank you! Awesome explanation:) $\endgroup$ – horn ochse Oct 28 '18 at 22:29
  • $\begingroup$ @horn If an answer helped you, you can upvote it. The additional information from your (deleted) answer can be edited in the question, which will bump the thread automatically. If you want a higher playbackrate you could consider caching the simulation or baking it to keyframes. $\endgroup$ – Leander Oct 28 '18 at 22:44
0
$\begingroup$

Unfortunately the current soft body physics solver in Blender is not fast enough to consider it as a usable thing, especially when making animations where the objects in the scene could be pretty complex with lots of polygons.

However, try lowering the number of polygons of your objects and see how much things speed up. Also, in Soft Body Edges settings turn off Edge and Face collision. You may also reduce the number of solver iterations in Soft Body Solver

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.