1
$\begingroup$

While panning the orbit with the MMB, the movement of the start-up file cube, as well as of any other object, is restricted only to the X and Y axes, while the Z axis is blocked. What have I done wrong? I could always move my objects with the MMB along all axes. Trying to reset, I have downloaded the latest version v2.79b but unfortunately the problem persists. I've searched for an answer, but found only ones that relate to extrusion Thank you for your help.

$\endgroup$
9
  • 1
    $\begingroup$ Is there blocked axis for rotating the viewport or rotating the object? $\endgroup$
    – Mr Zak
    Oct 28 '18 at 15:50
  • $\begingroup$ Are You sure it is not a HW problem? Rotating and resizing works well? $\endgroup$
    – Jan Matys
    Oct 29 '18 at 4:32
  • $\begingroup$ Mr Zak, the Z axis is blocked only when rotating the viewport. $\endgroup$
    – CGPrince
    Oct 29 '18 at 6:52
  • $\begingroup$ Jan Matys, I've tried another mouse but nothing is changed. Rotating and scaling of objects work OK on all axes. $\endgroup$
    – CGPrince
    Oct 29 '18 at 6:56
  • $\begingroup$ If in viewport then this behaviour is normal as that's what Turntable orbit style means and it's by default unless changed. To change in User prefs > Input change Orbit Style. $\endgroup$
    – Mr Zak
    Oct 29 '18 at 10:56
1
$\begingroup$

You seem to be referencing the cameras movement in the viewport accessible via MMB MMB, as said in your comment.

Mr Zak, the Z axis is blocked only when rotating the viewport.

By default, the Viewport Orbit Style is set to Turntable. For a less restrictive Orbit Style, set it to Trackball.

[The Orbit style sets] how Blender works when you rotate the 3D View by default when holding MMB MMB.

Turntable
Rotates the view keeping the horizon horizontal.

This behaves like a potter’s wheel or record player where you have two axes of rotation available, and the world seems to have a better definition of what is “Up” and “Down” in it.

The drawback to using the Turntable style is that you lose some flexibility when working with your objects. However, you gain the sense of “Up” and “Down” which can help if you are feeling disoriented.

Trackball
Is less restrictive, allowing any orientation.

Blender Manual

To set the Orbit style to Trackball, open the User Preferences window ⎈ Ctrl⎇ AltU and go to the Input rider. Then click on the Trackball button.

orbit style

$\endgroup$
0
$\begingroup$

try pressing the n key and checking that all the "lock" pictures are unlocked if it is locked, like in this picture locked

then you will not be able to move it in the z axis. if it is, just click it and it should change to the unlocked picture.

$\endgroup$
3
  • $\begingroup$ Triplex, thank you for your answer. All my location axes are unlocked, nevertheless, from now on I will always check this parameter. $\endgroup$
    – CGPrince
    Nov 27 '18 at 22:15
  • $\begingroup$ could you try uploading your blend file $\endgroup$
    – triplex
    Nov 28 '18 at 18:37
  • $\begingroup$ Triplex, as per Mr Zak’s answer, this behavior is normal. Thank you. $\endgroup$
    – CGPrince
    Dec 4 '18 at 2:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.