0
$\begingroup$

So i was making an object and following a tutorial on unwrapping and texture painting. I followed everything correctly and got to where i am. As i was going to start with the gif making process (excuse the armature), i noticed something.

The texture continued onto it's back area which was odd (and pretty funny) to me because i never painted that on. When i had it all unwrapped onto the image texture and could see the entire outline of the body, not once did i paint on the extra faces.

I supplied my nodes too in case something is wrong with those but i have been searching through videos and forums looking for an answer and not once found one.

Thanks in advance!

$\endgroup$
  • 1
    $\begingroup$ That should be because UV map of your mesh which isn't shown on the screenthots consists of mutliple UV islands and each one of them sits on the black drawing (at least partially). Probably you have automatic unwrap without any seams or something along those lines. Note that texture will get repeated once outside of the grey borders in the UV editor $\endgroup$ – Mr Zak Oct 27 '18 at 21:30
3
$\begingroup$

As Mr Zak said, it's probably because of a bad unwrapping, some of your UV islands must overlap due to the unwrap method you've chosen, which can be ok in some cases but not if you decide to paint your character, because what you paint on a face will also be painted on another one.

You need to check your UV/Image Editor to understand what happened, typically I guess each of your back faces must fill the whole surface of the texture.

For your purpose the best and easiest way is to first select all the faces of your mesh and U unwrap with the Smart UV Project option: This way you're sure that you've got really distinct islands and none of your face will overlap another one on the UV/Image Editor.

enter image description here

Please select one of your back faces and look what happens, I guess something like this:

enter image description here

$\endgroup$
  • $\begingroup$ Yep, i had to go back and re unwrap it. I rewrapped it again this time properly and added it's texture paint. It finally came out perfect! Thanks for the help! $\endgroup$ – user63988 Nov 9 '18 at 22:09
0
$\begingroup$

i'm not actually sure why that would be happening, but an easy fix would be to make another material for the rest of the body, so i'm using a cube and a car image like this:enter image description here

then in edit mode select the faces that u dont want to have the image (you could select the ones u do want and press ctrl+i)enter image description here

then you wanna make a new material, use the eyedropper colour on ur green from the original material, and plly it to the selected faces like this:enter image description here

And there u go! that should work.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy