1
$\begingroup$

This is my first question here. I have been looking but haven't found a proper answer. Hope someone can put me on the right track. I have painfully built a scene, with a lot of problems because I cannot seem to be able to move it smoothly even in wireframe mode. When I look at the memory usage, at most it gets to 8gb. I have 16 installed (Mac 27" High Sierra iCore5 AMD Radeon R9 M380 2048 MB) I'm not concerned with render times, but with being able to work smoothly a comfortably not having to see the spinning wheel every time I move around the scene.

My questions are: Is it normal to have such a poor performance in the viewport even in wireframe (details of scene attached)?? If not, how do I fix this? Having more memory would solve this issue? Having a eGPU solve this? Again, not concerned with time renders but with viewport performance.

If none of the possible solutions I have thought of will do, ahoud I consider getting a new mac (don't say windows is better, I know but this is not my point, since I need mac for work and I cannot shift to windows)

Thanx in advance and sorry for the long question. A bit desperate and lost here :-(

Scene Info

System settings

$\endgroup$
0
$\begingroup$

I sympathise with you @Arqueo Artis

I use a MacBook Air 16", My school computer. Its a pile of ****.

There is one simple fact:

You cannot have complex meshes. As you said it restricts production.

Though, if you have multiple meshes, use blenders layers. Use one to construct on, the others hold the rest. Just note, when you render you have to select all the scenes your objects are on.

If it is a sculpt, you are just going to have to reduce polygons.

I recommend using the modifier decimate. Though it is slow to tweak with high polygons, you can normally reduce polygons in massive amounts without losing much detail.

If you are using any particle effects, just hide them until you need them.

BTW: I find object mode and sculpt mode the fastest. Wireframe mode is usually quite slow. I am fairly sure blender doesn't worry about vertexes behind faces, but don't quote me on that :-).

That's what I do anyway.

Good luck and I hope I helped,

BFB

$\endgroup$
  • $\begingroup$ Thank you so much for the answer. I am already using layers. If I hadn't there is no way I could have finished that scene. I wonder if more memory o an eGPU will do I'm also considering buying a new computer.. really puzzled :O $\endgroup$ – Arqueo Artis Oct 28 '18 at 22:02
  • $\begingroup$ Adding an eGPU will most likely only speed up renders. You will need a better CPU to do what you want. If you want to stick with apple, Look at the iMacs. But if you are already experiencing difficulties as is, you may need to look for a custom computer as the apple range doesn't get much better. Good luck $\endgroup$ – Bigfoot Blondy Oct 28 '18 at 22:46
  • $\begingroup$ Thanx! I have an iMac (specs above), but I was thinking upgrading to i7 core and Radeon pro 589 8gb if the answer was just the one you gave :-) . Guess this will do? $\endgroup$ – Arqueo Artis Oct 29 '18 at 2:50
  • $\begingroup$ Wow, considering such a big gap in the intel core version, it may be worth it. I recommend getting in contact with someone who has the newer model and testing it out using Blender. Bump up vertices, test the scene you currently have, do test renders etc. Then you can get a better idea if it will be worth the purchase. I am sure Apple will try to help you out in some way or another. Youtube stations /render farms often have many iMacs due to their great rendering abilities. You should go try it out. Best of luck $\endgroup$ – Bigfoot Blondy Oct 29 '18 at 2:58
  • $\begingroup$ Thanx! It would be awesome to test the file in a mac of that characteristics. Not sure apple guys will let me test it... in my store are a little jerks :-( Will try to find someone anyway. Thanx again! You really helped! $\endgroup$ – Arqueo Artis Oct 29 '18 at 9:57
0
$\begingroup$

Have you tried turning on X-ray mode?

https://www.youtube.com/watch?v=neTlP6Yna5w

I've had poor viewport performance issues in 2.81 and it helped in my case.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.