1
$\begingroup$

When rendering my mesh, I noticed that not all the textures for the body are the same as they are in the 3D view. In my body mesh, there are two textures- one for the head, and one for the rest of the body. The head texture shows up fine during rendering, but the body texture appears to have its UVs somehow warped.

3D View

Render

Blend file

As you can see from the body texture on render, the body texture IS being used to texture the body since the blue on the arm is present (not found in the face). However, it would appear that the UVs are different on render than in the 3D view. Any ideas?

$\endgroup$
  • $\begingroup$ @ideasman42 I suggested that the OP ask this as a separate question, since it isn't really related to the lighting issues from the previous post.. $\endgroup$ – gandalf3 Jun 12 '14 at 0:42
  • $\begingroup$ This is happening because the head texture is overriding the body texture, so head texture is being used to texture the body. $\endgroup$ – gandalf3 Jun 12 '14 at 0:50
  • $\begingroup$ It's actually overlayed, and as the head texture is transparent where the arm UVs are, the body texture shows through. You can fix this by removing or disabling the textures in Properties > Textures, then enabling face textures in Properties > Materials > Options. See this comment. $\endgroup$ – gandalf3 Jun 12 '14 at 1:20
1
$\begingroup$

It is necesary to have two materials and assign the respective faces to them according to texture they should be using. One material for the head and one for the body. Each using it's own texture.

How it's done:

Add new material to the object in Properties by pressing the light grey button on the right with a white + in it.

Name the old material "Head" and disable the Body texture in the Texture tab.

Name the new material "Body".

Select the "Head" material and press the dark grey button with the black arrow pointing down and choose "Copy Material" and then select the Body material and click this arrow again and press "Paste Mateiral".

Then go into edit mode, select one face which should be using the body texture and press Shift+G and choose "Image". This selects all faces that have the same texture mapped.

Now while having the faces selected click on the Body material and press the "Assign" button to assign selected faces to the material.

Then go into the Texture tab and uncheck the Head texture.

It should work now!

One tip: always name your materials, naming objects is also good, but materials are more important because they get reused often.

Fixed blend file: http://www.pasteall.org/blend/29840

$\endgroup$
  • $\begingroup$ Once you have the materials properly sorted out; you can temporarily join them as 1 mesh then create a new UV set and bake the whole thing to one texture if that's what you want. Now you can separate the mesh as you like and just use 1 material and texture for both. $\endgroup$ – MarcClintDion Jun 20 '14 at 1:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.