1
$\begingroup$

screw modifier

I was trying out the shape key addon using this demo SVG. The morphing works fine, but when I apply the screw modifier the normals look reversed for both the shapes. How can this be fixed?

$\endgroup$
  • 2
    $\begingroup$ Have you tried the 'Flip' checkbox in the Screw modifier? $\endgroup$ – Robin Betts Oct 25 '18 at 11:16
  • 1
    $\begingroup$ It looks like it's the problem, I think you can put it as an answer $\endgroup$ – moonboots Oct 25 '18 at 11:24
  • $\begingroup$ @RobinBetts Yes, that was it. Thank you! If you could just put it in the answer, I would mark the question as answered. I have another related question. Will create a separate topic for that. $\endgroup$ – Blender Dadaist Oct 25 '18 at 14:23
0
$\begingroup$

You probably need to set the 'Flip' checkbox in the Screw Modifier. ;)

$\endgroup$
  • $\begingroup$ Or, come to think of it, put a '-' in front of the Angle... $\endgroup$ – Robin Betts Oct 25 '18 at 14:37
  • 1
    $\begingroup$ :) Yep! And apparently, Blender follows the right hand thumb rule here also, just as in case of setting normals to the faces. So another way of achieving this is to reverse the curves in the source SVG. $\endgroup$ – Blender Dadaist Oct 25 '18 at 15:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.