2
$\begingroup$

I'm trying to add a dirt texture with small rocks as a foundation for a landscape, but I have a familiar problem: when the camera is directly overhead, the texture looks 3 dimensional. However, when looking horizontally, it goes flat. How do I make it bump at all angles? I should mention there is a colour image in the image texture input node going into the colour input of the principled shader as well as a height image in the bump and roughness).

Here's the overhead view:

enter image description here

Here's the horizontal:

enter image description here

Here's the node setup:

enter image description here

$\endgroup$
4
$\begingroup$

In your case it looks like a Bump or Normal map won't be enough to give a 3D effect. You can use the micro-displacement method as explained by Valentin (never tried) or you can use the Displacement modifier:

  • Subdivide your ground so that you will be able to deform the surface.
  • Give it a Displacement modifier.
  • Give it a Subdivision Surface modifier so that it will smooth the effect. Choose a Subdivision value of 2.
  • Also, on the T (Tools) panel > Tools > Edit > Shading, press Smooth.
  • In the Properties panel > Texture, choose Displace in the top dropdown menu, and in Image load the DISP picture you've used in the Node Editor (in the Image Texture node before the Bump node), but maybe even your color texture will be ok.
  • In the Displace modifier make sure the good texture is selected, play with the Strength value to find the right amount of effect.

enter image description here

| improve this answer | |
$\endgroup$
  • $\begingroup$ This worked! Thanks! Too bad it has to be more subdivisions and polygons, but it is much more realistic looking $\endgroup$ – lakerice Oct 22 '18 at 17:54
  • 1
    $\begingroup$ To recreate this kind of soil with much less polygons, you could also create a grainy soil with a picture and a simple Bump node (like you've done before but with a different picture with no big rock), then create 2 or 3 low-poly 3D rocks, link-duplicated them (alt D), scale them up or down, rotate them, and put them on your ground. $\endgroup$ – moonboots Oct 22 '18 at 19:39
  • $\begingroup$ Ah this is a good idea! I have a small rock pack already but I could maybe use them as a particle system and scatter them with a bump texture. The only thing is that it would still have to be covered significantly enough I would think to avoid showing the inevitable flatness $\endgroup$ – lakerice Oct 23 '18 at 19:41
  • 1
    $\begingroup$ Yes I also thought about particle system, you really need to test these different solutions to see which one fits the best $\endgroup$ – moonboots Oct 23 '18 at 19:49
  • $\begingroup$ That is incredible. That beats laborious node compositing. $\endgroup$ – Rita Geraghty stands by Monica Dec 23 '18 at 9:37
4
$\begingroup$

The best way achieve a "bump" from all angles is using micro-displacement.

Replace your Bump node with a Math node and set it to Multiply. Then connect the Math node with the Displacement input of your Shader Output node. Play with your Multiply value to get the result that fits your scene.

This will not work until you add extra geometry to the plane. The most efficient way to do that is using a Subsurf modifier. Set it to Simple so it doesn't smooth the plane and Adaptive so you get optimized memory and render times. If there's no option that says "Adaptive" you have to change from "Supprted" to "Experimental" feature set in the Renders tab under "Render". Then down in the Material tab in the Properties under "Settings" set your Displacement to either "Both" or "True". "Both" gives you the option to still add a bump map on top of your displacement.

Then you can enter rendered view and enjoy your displacement! Note that the displacement doesn't update in rendered view. Switch from and back to rendered view to refresh the displacement.

| improve this answer | |
$\endgroup$
  • $\begingroup$ Hm for some reason I keep running out of memory when I use the adaptive feature. Does this require a significant amount of memory? $\endgroup$ – lakerice Oct 22 '18 at 17:31
  • $\begingroup$ Does your plane already have more than the initial four vertices? $\endgroup$ – Valentin Walter Oct 22 '18 at 17:53
  • $\begingroup$ yup it was sub-divided several times and then had sub-surf $\endgroup$ – lakerice Oct 23 '18 at 19:21
  • 1
    $\begingroup$ Then remove all subdivisions and only use the Adaptive Subdivisions. This should fix your memory problem. The advantage that this method has over moonboot's is that Adaptive Subdivision should use less memory and render time with increased detail. There's an in-depth video on the subject from Blender Guru if you wanna check it out: blenderguru.com/tutorials/…. $\endgroup$ – Valentin Walter Oct 23 '18 at 19:29
0
$\begingroup$

I have some pages from my scrapbooks that would greatly interest you. I took screenshots of nodes few months ago.

Check out page 94 in link below. https://docs.google.com/presentation/d/1kP0Dz1VFLIlgzykHcc00eIzvZoAtVO0okPSmD7CU1mo

This next page might be different: page 122 on broken tiles and debris on ground. https://docs.google.com/presentation/d/1ggss5H_XdWtIZ825iRuUjk7svvzdoPWM-cP1yv4kCCc

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.