0
$\begingroup$

I'm trying to change the location, rotation, scale and dimensions of many objects at the same time. It's about 80 planes mapped with different textures. I've imported these planes using the addon "image sequence as planes". After having selected every plane,I see that I can change the value of only one plane. Is there another way to do this ?

selected objects in blender

$\endgroup$
  • $\begingroup$ It really depends on what you mean precisely, you could parent them all to the same object and transform the object, but will it satisfy your need? $\endgroup$ – moonboots Oct 21 '18 at 21:24
  • $\begingroup$ yes if it works. I've just tried. I've selected all the planes together and then I have parented them to an empty object. After this I have changed the value of the Y axis on the empty object to 0. When I click on the planes I see that they haven't changed the y value to 0 $\endgroup$ – Marietto Oct 21 '18 at 21:44
  • 1
    $\begingroup$ maybe join them all with ctrl J, make your transforms, the separate by loose parts? I don't know, maybe you should explain more precisely what's the situation and what you're trying to do, I think it lacks precisions... $\endgroup$ – moonboots Oct 21 '18 at 21:53
  • $\begingroup$ or maybe unparent your object from your empty (alt P) with the keep transform option? $\endgroup$ – moonboots Oct 21 '18 at 21:57
  • $\begingroup$ only joining the planes with ctrl J and so on worked. $\endgroup$ – Marietto Oct 21 '18 at 22:16
2
$\begingroup$

If I understand it correctly and you just need to set the same value for multiple objects at once, there is simple trick for this purpose:

  1. Select all the objects
  2. Click the input field while holding Alt
  3. Enter the value

enter image description here

In the default behaviour, new value is set only for the active object (the last selected one).

$\endgroup$
  • $\begingroup$ thanks for the trick, you talk about the default behavior, so what's the non-default you're using? because when I try your method, the new value is set only to the active object, the other objects also move but not to the entered value $\endgroup$ – moonboots Oct 22 '18 at 7:43
  • $\begingroup$ it seems that it works good... $\endgroup$ – Marietto Oct 22 '18 at 10:11
  • $\begingroup$ @moonboots - do you hold Alt while clicking into input field? $\endgroup$ – Jan Kadeřábek Oct 22 '18 at 21:56
  • $\begingroup$ yes, maybe it's my settings, I don't know, I'll try to find out, thanks ;) $\endgroup$ – moonboots Oct 23 '18 at 7:16
  • $\begingroup$ FYI, I am using Blender 2.79, maybe it doesn't work in some earlier versions. $\endgroup$ – Jan Kadeřábek Oct 23 '18 at 20:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.