3
$\begingroup$

I am working on a vfx creature for a movie, and I've run into a very specific issue. I haven't found anything on any forum that helps fix this issue.

I modeled and rigged a topology version of a hires sculpt, and everything was working fine. When I began the materials for the creature, I baked an AO map from the hires to the topology, which also worked fine. Then I baked an AO map from just the topology onto a separate texture in the hopes to blend the two. It baked successfully, but shortly after blender crashed.

An autosave file was available and would take me back to just after the second bake, and any command or change related to the topology object caused blender to crash.

Further, I can append every other object to a new blend file, except "Plane" the topology object (bad habit of not naming I know). This single object cannot be accessed or changed, and the autosave file has since been crashing on startup along with the original file.

I've tried opening the file on a different iMac, no luck. Changed to a different version of blender, still no. Every tip and trick and workaround to a blender crash has also not worked, I am out of options.

I am in dire need of this object, sweating heavy bullets here. If anyone can help me figure this out I am getting you a credit on this movie.

Below is the crash report saved in the /tmp:

# Blender 2.79 (sub 0), Commit date: 2018-03-22 14:10, Hash f4dc9f9 
bpy.context.scene.cycles.film_transparent = False  # Property
bpy.context.space_data.system_folders_active = 4  # Property
bpy.context.space_data.system_folders_active = 4  # Property

# backtrace
0   blender                             0x0000000100c837ea BLI_system_backtrace + 58 
1   blender                             0x000000010013f6fa sig_handle_crash + 362
2   libsystem_platform.dylib            0x00007fff6412bf5a _sigtramp + 26 
3   ???                                 0x00000001165c9d2a 0x0 + 4670135594 
4   blender                             0x0000000100993c89 modifiers_calcDataMasks + 249 
5   blender                             0x00000001008a2a9e mesh_calc_modifiers + 654 
6   blender                             0x00000001008a24e3 mesh_build_data + 147 
7   blender                             0x00000001009b79cf BKE_object_handle_data_update + 495 
8   blender                             0x00000001009b1829 BKE_object_handle_update_ex + 441 
9   blender                             0x0000000100a02557 scene_update_object_func + 295 
10  blender                             0x0000000100c83b07 task_scheduler_thread_run + 279 
11  libsystem_pthread.dylib             0x00007fff64135661 _pthread_body + 340 
12  libsystem_pthread.dylib             0x00007fff6413550d_pthread_body + 0 
13  libsystem_pthread.dylib             0x00007fff64134bf9 thread_start + 13

Greatly appreciate.

Joe

$\endgroup$
  • $\begingroup$ Possibly a problem with the modifiers on that object. What modifiers were in place? If high level subdiv surface, could try enabling Simplify settings to limit the subdiv - might reduce memory overhead to let you handle that object. Also, could try latest build (2.79.6?). Are you using Standard or Experimental featureset? $\endgroup$ – Rich Sedman Oct 21 '18 at 7:17
1
$\begingroup$

From your trace it appears to be a problem with the modifiers - possibly resulting in either too many faces (so exceeding the available memory) or producing geometry that is causing Blender to hit an exception and abort.

If the problem is due to Subdivision Surface producing too many faces then you may be able to work around the problem by setting Simplify settings in your Scene properties panel before you import your object into another Blend file.

If the problem is due to the rendering in the 3D View then you may be able to open the file by disabling the 3D View on opening. This can be achieved by opening Blender (without loading a file), change the 3D View window to something else (eg, UV/Image Editor), go to File/Open... and uncheck the Load UI option in the tools panel on the left before selecting your file to open. This should open the file while retaining the current UI windows (eg, UV/Image Editor) so Blender does not try and render the scene in the viewport.

You could also try using one of the more recent development builds of Blender - eg, 2.79.6 - as these do include significant enhancements and bug fixes, especially to some of the Experimental features (such as True Displacement) which could potentially be causing issues.

$\endgroup$
  • $\begingroup$ The due date for the project forced me to restart from a basemesh that I had made a depressing amount of progress from. Gotta nite the bullet sometimes. Following up because the same issue actually happened again (I saved back ups about every 10 mins this time so I was fine) so I’m curious to pursue this Incase it happens again in the future or to anybody else. $\endgroup$ – Josiah Hunt Oct 23 '18 at 8:21
  • $\begingroup$ @JosiahHunt Does that mean my suggestions didn’t help at all? I think you’ll need to provide more information for someone to be able to take this further. $\endgroup$ – Rich Sedman Oct 23 '18 at 9:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.