17
$\begingroup$

How can I toggle between vertex, edge and face selection in Edit mode?

enter image description here

$\endgroup$
33
$\begingroup$

Its the 1, 2 and 3 keys above the letters (not the numbers pad)

$\endgroup$
2
  • 1
    $\begingroup$ Those hotkeys do not work on an MPB with the 2.8 official release, even with 'Emulate Numpad' disabled. Further there appears to be no way to switch selection modes through the menus. The three selection mode icons in the screen capture above are not displayed. $\endgroup$ – Rjak Sep 28 '19 at 3:38
  • 1
    $\begingroup$ This saved my life. I hate how many unfixable UI issues blender has, like not showing the shortcut for these buttons when hovering over them like random other buttons happen to $\endgroup$ – Andy Ray Mar 15 '20 at 3:41
12
$\begingroup$

I'm using Emulate Numpad, and in this case 1, 2, 3 are assigned to change views (front, side, ...), so these keys don't work anymore to toggle between vertex/edge and face select mode.

So what I did is change the hotkeys assigned to vertex select mode, edge select mode and face select mode to Shift + 1, Shift + 2, Shift + 3.

Here's how to do it:

  1. go to Edit > Preferences > Keymap
  2. Go to the field next to Name enter Select Mode

search for select mode

  1. Now you should see under Mesh all the hotkeys for the different selection modes (for me, none of them works to toggle between vertex/edge/face select) I changed the first 3 to the keys that suit me, you can also choose different ones.

original hotkeys for different selection modes

  1. To change the key, just click on the field on the right with the 1 for example, then it tells you to press the keys you would like to switch it to (I choose Shift + 1 which appears in the field as Shift + Numpad 1 but the key I press to go to Vertex select mode is Shift + 1, so probably that's also because I use Emulate Numpad.

changed hotkeys

$\endgroup$
2
  • 1
    $\begingroup$ Many Thanks. I use Emulate Numpad and for me, 1, 3, 7, for switching views was so baked into my head that I left those as they were and thanks to your post have now got 2,4,6 for vertex/edge/face selection mode. Again, Many Thanks. Much appreciated. $\endgroup$ – user3849061 Feb 28 '20 at 8:32
  • $\begingroup$ Welcome :) I'm happy that it was helpful!! The only thing I realized recently is that with Blender 2.82, you can have edge/vertex/face select on at the same time! so I usually forget deactivating for example edge select when switching to vertex select, and loose some time there... but I guess I'll get used to that :D $\endgroup$ – buesi Feb 28 '20 at 17:24
2
$\begingroup$

With respect to Blender 2.8(2018-12-02), using a Mac PowerBook, before the 1,2,3 buttons work...you must: Go to the Edit Menu > Preferences > Uncheck 'Emulate Numpad'.

Hopefully, saves someone some time!

$\endgroup$
1
$\begingroup$

Just in case anyone else was having an issue with these tools dissapearing all together, make sure you have only the object selected that you want to modify! I had multiple objects selected apparently and could not find the option to toggle the modes at all.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.