0
$\begingroup$

Blender Version 2.77 I’ve been working on a render of a lightbulb recently and I have been having troubles with material slots. I have the materials shows below assigned to certain vertex groups that I selected and then hit the assign button in edit mode to assign the material. Note: I have no textures, only materials.

enter image description here

So the main problem though is the materials that I assigned not showing up in final render. It shows the assigned materials in render preview and the material view but never the final render.

Here is render preview: enter image description here

Here is the final render: enter image description here

As shown above the render preview shows the assigned materials while the final render shows only the first material slot. Also remember that there is no textures and I have made sure that the correct faces are assigned as well as all nodes are connected.

Object screen:

enter image description here

I can provide more information if necessary.

$\endgroup$
  • $\begingroup$ Materials aren't assigned to vertex groups, they are applied by face. blender.stackexchange.com/questions/516/… $\endgroup$ – Duarte Farrajota Ramos Oct 18 '18 at 0:41
  • $\begingroup$ They were only using the vertex groups as a middlemanr to select the vertices; after they were selected, they were assigned to the material in question. $\endgroup$ – Lee Oct 18 '18 at 1:24
2
$\begingroup$

It look more that your material isn't doing what you want it to do, as opposed to being improperly assigned. Look on your render properties tab, and see how you're telling blender to handle transparency. You might need one or more of the following:

--More transmission bounces. This lets the ray bounce around a few more times (in this case, through a few more surfaces) before giving a result back to the render engine. If it's set pretty low, you can end up with fairly opaque materials, because you have to bounce it through its surfaces (front AND back) and return through the same way to the camera. I'd recommend at least four more bounces than your minimum bounce number, but twice as many as your highest bounce is ideal. If you're trying to make less-noisy glass (my heart goes out to you friend) try increasing clamp indirect, instead, or play with the Light Path node in your material.

--More render samples. This is in the same vein as above, but it's important to note the maximum value should be your highest bounce number, and your minimum value should be your lowest bounce number. If your preview bounces are higher, this could be exactly your problem. Preview is what you see in render view in the viewport and Final is what you see when you hit the Render button. They don't have any bearing on each other, and can be totally different. Your Final value should be at least as high as your highest bounce for best results, but you actually can get away with less in most cases; you'll have to play around with it to see what works for your scene.

--Enable or adjust transparency. Sometimes, for some reason, this isn't checked. I assume for performance reasons, as it can be computationally expensive in many cases. If you can't find it, look for a collapsed menu that says 'shading'. You'll want Ratrace selected, and your alpha slider anything greater than zero. I'm not sure if this specifically was only a Blender Internal option. You might not have all of those settings, but transparency should still have it's own section or subsection. The main point is to make sure you're not using the world material for your transparency mixing.

Alternate things to look into:

--Check your material settings. Make sure your material is doing what you want it to do. It could be that it's a little too reflective, and all the light is bouncing off instead of passing through. You can adjust this by mixing in a Transparent node, with Layer Weight as a mix factor (you'll want the transparency plugged into the top slot, and I find while Fresnel gives more accurate results, Facing is more visually appealing).

--Adjust your lighting. I'd say easily eight times out of ten, if your render isn't looking right, it's because your lighting is off. From the look of your render, the light is shining directly onto the lightbulb. Because of the way Blender calculates Fresnel, which is automatically included in the Glass node, anywhere light shines directly onto something is going to be less transparent. Simply changing the position so it's on a different angle than the camera could very well improve your results. This includes the light coming from the filament. The filament should be brighter than any other lightsource, if you want it to be on.

--Thicken your glass. Instead of making it a single solid shape, make it a shell. That is, with visible thickness. This will make the glass the thin shell you're trying to tell Blender to render, instead of the thick solid mass it thinks you want. I don't remember when the thickness modifier showed up, but this is perfect for this task, and it'll save you a few vertices. If you don't have the thickness modifier, or just don't want to use it, copy your glass vertices, shrink them slightly (ALT + S is best for this kind of object) until it's the thickness you want, then flip the normals via the tool panel. There should be an option on the tool shelf, but if there's not, searching 'flip normals' will bring it right up for you.

--Adjust your environment. Give your lights more places to bounce off. As it stands, you have the lightbulb and your plane. This isn't enough for the resutls you want to achieve. Make a cube or sphere around your scene just big enough for your camera, lighting, and objects. Make sure the normals are pointed inwards. If you want it invisible, don't make it transparent, the rays will just go right on through. Either use a Holdout node, which will make it like a hole to see the world background, or mix in a Transparent node with your original texture and plug Camera Ray (on the Light Path input node) into the mix factor. This will make it invisible to the direct camera rays, but allow light to bounce off for things like reflections and indirect lighting. Your nontransparent material for this can be anything opaque, but rougher object will bounce softer light than smooth objects, and brighter colors will bounce more light than darker ones.

I hope this helps! Happy Blending!

$\endgroup$
  • $\begingroup$ I've tried all of what you said above but it still is not assigning the materials in the final render. In this image I moved the filament material up on the material list and it changed the whole mesh. $\endgroup$ – Skyler Hanson Oct 18 '18 at 15:14
  • $\begingroup$ So did you solve it? I wasn't entirely sure by your answer. $\endgroup$ – Lee Oct 19 '18 at 6:17
  • $\begingroup$ Yes, it was just a modifier not being shown in the final render. $\endgroup$ – Skyler Hanson Oct 20 '18 at 4:30
1
$\begingroup$

Okay, I've learned something very important. Not only make sure the mesh is showing or not showing in final render or the viewport, but also check the modifiers.

I found that the remesh modifier was showing in render mode but not the viewport and this was causing a crap ton of problems.

So the lesson is. Make sure to check your modifiers. Also remesh sucks.

$\endgroup$
  • $\begingroup$ I'd just like to point out that remesh can be very useful! ... But only in certain cases. (: $\endgroup$ – SilverWolf Oct 19 '18 at 1:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.