0
$\begingroup$

Ok, Im trying to mimic the "firefly" particle systems available in unity, where the particles "glint" but more so move around in a swarming way: https://www.youtube.com/watch?v=9O5XU_jshBU

Ive just turned off gravity and added turbulence to my particle system, however Im still not getting the swarming:

enter image description here

What is wrong here?

$\endgroup$
1
$\begingroup$

You should add a Force Field. [Shift + A] -> Force Field -> Turbulence

Adding a turbulence field

Make sure it's in the same layer as the particles object you want to affect, to get the a turbulent flow of the type you linked.

It looks like what you did was add turbulence to the Particle System in the Force Field Settings tab, which makes each individual particle act as a force field (if you turn on Self-Effect in that tab, you'll see how this affects the particle system).

The Field Weights settings tab controls how much each type of force field affects the particles.

| improve this answer | |
$\endgroup$
0
$\begingroup$

This sort of thing you normally get in animation. The parts you also need to look at is how long the lifespan of each particle is. If you know you have everything set up correctly, it may simply be that you aren't seeing it because you aren't in the correct frame. Make sure you have more than one frame in your timeline, then scrub along it. Could be you've already done it! Alternately, take a quick look via rendering it; some feature just don't show up in viewport in Cycles, but show up in the final product.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.