2
$\begingroup$

Here is my problem. When I try to render with my GPU the image (mainly the lights) are not the same as with my CPU. The image is more grainy with the GPU than with the CPU and even if I do not change any parameter from one rendering to another. I would like to be able to use my GPU to save time with my rendering

My config :

CPU : AMD Ryzen 2700x GPU : EVGA GTX 1070 Blender version : 2.79

I can'T upload the .blend files because he is pack with all the texture (more than 600MB)

Exemple

$\endgroup$
  • 1
    $\begingroup$ Edit your question and share the file, please. You can upload it here: blend-exchange.giantcowfilms.com Also - what version of Blender are you using? $\endgroup$ – Martynas Žiemys Oct 16 '18 at 17:35
  • $\begingroup$ Can't upload the project files too heavy (more than 600mb with all the HD textures) $\endgroup$ – Gabriel Oct 16 '18 at 17:56
  • 1
    $\begingroup$ I think more info is needed to determine the problem. Is it maybe possible to remove the parts of the scene that do not contribute to creating the problem? One way or another one would need to recreate the problem to start figuring out, why it's happening. Could you maybe at least share the screenshots of your render settings and tell more about how the scene is constructed? $\endgroup$ – Martynas Žiemys Oct 16 '18 at 18:24
  • $\begingroup$ maybe it has something to do with tile size and samples. Have you tried changing your tile size to 256 when you switch to GPU. Its should be 16 or 32 when its on CPU. Maybe that is throwing the sample count off. $\endgroup$ – icYou520 Oct 16 '18 at 20:52
2
$\begingroup$

I think I found my problem. It is related to the shader "volume scattering" that I put in the world settings in the "volume" if I remove this option my CPU rendering become identical to my GPU rendering. I found on several website people who say that there is a problem with the "volume scattering" and the CUDA.

https://blenderartists.org/t/cycles-gpu-renderer-cant-render-volume-scatter/647962

https://developer.blender.org/T50808

https://blenderartists.org/t/volume-scatter-with-gpu-worse-than-with-cpu-in-cycles/651603

$\endgroup$
0
$\begingroup$

The picture is small, but it looks like fireflies.

You can eliminate them by going on Render -> Sampling and inputting a value between 1 and 2 in the Clamp field.

It should make your render smooth again.

$\endgroup$
  • 1
    $\begingroup$ The issue is a bit more complex than that if the results differ when rendering with CPU and GPU. They should be identical. Logical clamping values are also dependent on the specific scene. Your advised value is arbitrary and might decrease the quality of the render severely if the lights used are stronger. I would not consider this to be a good advice. $\endgroup$ – Martynas Žiemys Oct 16 '18 at 19:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.