4
$\begingroup$

I need to render a world position pass in Blender to check if my idea is correct. I found solution that uses an emissive material and geometry node to render position as colors: How to render world position pass

enter image description here

When I render the scene presented below:

enter image description here

I get this result:

enter image description here

The image seems to look fine, but when I check the values with the image view something's wrong.Each cube is size of 2 and spacing is equal 1. Cubes are translated in x direction and the first-left one is placed in origin. I assume then that the first-right cube should have values of R component within the range 12-14. Intead of that values are around 2.7. What do I do wrong?

---EDIT---

I did everything as Martin recommended. Anyway I still have same problem:

enter image description here

I attach the .blend file where the problem occurs. I will be very grateful if you find the problem: https://drive.google.com/file/d/1bMnmEB9-j2OQllZKqfwwWkgx2ZlvTFx3/view?usp=sharing

$\endgroup$
  • 2
    $\begingroup$ Color management? $\endgroup$ – Martin Z Oct 16 '18 at 10:39
  • $\begingroup$ Any tips, what I should set in color management? I tried a lot of variants. The most logical one would be Raw mode in my opinion. There is no one named 'linear'. $\endgroup$ – Krzysztof Wolski Oct 16 '18 at 11:20
4
$\begingroup$

Try setting Display Device to 'None'(because you do not want it to be an image viewd on any display device, but only pure unchanged values) in the scene's color management settings:

enter image description here

Seems to work:

enter image description here

Obviously the output needs to be a 32bit full float EXR image in this case as well if you want to save it.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.