1
$\begingroup$

Sounds like I'm having the same issue as this question (Missing cache error) but since that has no answers, I figured I'd post this question with a working example of my issue.

I have a bunch of tubular structures that I build and mesh using metaballs. The issue is that sometimes there is a small amount of overlap between the meshes so I've written a script which uses soft body collisions to reduce the overlap (this may be overkill but I've found no other satisfactory way to do it).

The problem is that when I have more than a couple of meshes, I get this 'missing cache error' being printed to the console over and over again. It doesn't actually stop the simulation but that much printing to the console slows the whole process down.

You can download the .blend file with ten meshes and the soft-body script in it to see the problem for yourself here .

Does anyone know the cause of this error message, whether it actually affects the result of the simulation and how to stop it?

$\endgroup$
1
$\begingroup$

Not exactly a general solution to the missing cache error but I solved my problem.

I think the error has something to do with the physics simulations running with all the separate meshes that have no physics modifiers attached to them alongside the meshes I'm interested in that do have the physics on.

I solved this issue by using collision groups so that each mesh only interacts with those that it overlaps with anyway.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.