2
$\begingroup$

I'm trying to animate a camera path using 2.8. I've got a camera clamped to a nurbs path and I want to zoom in and out a bit as my camera is tracking. However I can't seem to keyframe the field of view on the camera. Did that get lost in 2.8 or am I just doing it wrong? Under the Lens parameters I can keyframe Type, Lens Unit, Shift and Clip but no little dot next to FoV. Sup with that?

Thanks

Edit: screenshot

$\endgroup$
6
  • $\begingroup$ Can you provide a screenshot? I think you search for option named "Focal Length" $\endgroup$
    – Crantisz
    Oct 12, 2018 at 15:21
  • 1
    $\begingroup$ I'm voting to close this question as off-topic because this is likely a bug in unfinished experimental development software $\endgroup$ Oct 12, 2018 at 15:49
  • $\begingroup$ Duarte are you sure it's a bug? They changed the window system and unless you know how it works it seems a lot like a bug, so I would appreciate leaving this open until someone has some insight. Unless there's a separate forum for the beta you would redirect me to. Crantisz I added a screenshot. $\endgroup$
    – Tim
    Oct 12, 2018 at 16:21
  • $\begingroup$ I'm most definitely not sure of anything, since 2.8 is unfinished it is impossible to know if it's a bug, unfinished implementation or user error. Since those things are expected to be ironed out by release, developers are aware of ir, there is no long term value in these answers, hence why it is considered off topic. Until then you should use blender artists to discuss these issues $\endgroup$ Oct 13, 2018 at 13:02
  • $\begingroup$ @Duarte Not a bug. It's the same in 2.7x $\endgroup$
    – Leander
    Aug 12, 2019 at 19:04

1 Answer 1

2
$\begingroup$

Agreed, it is odd, that the FoV is not keyframeable. However, you can just switch it to "Millimeters" instead of "Field of View".

$\endgroup$
1
  • $\begingroup$ I have a driver that use 2*atan(h/(2*d))*180/pi where h is height and d distance, how would i make it work in millimeters ? I've tried make fov=sensorwidth/tan(fov/2) but it doesn't work, i also tried 2*arctan(x/(2f)) but it doesn't work either... $\endgroup$ Apr 25, 2022 at 19:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .