Recently Blender version 2.79 and older crashes upon startup in my Windows 10 64-bit computer, and after further inspection, apparently it has something to do with the Cycles renderer. Blender 2.80, strangely enough considering it's still in alpha state, works fine, until I activate the Cycles renderer method and crashes itself too.

What I mean by crashing is the application freezes forever, making Blender prior to version 2.8 unusable in my computer. I tried fresh install from official installer, nightly build, updating the GPU driver, and nothing changed after following the troubleshoot procedure. When Blender freezes, the Task Manager shows Blender is using 25% of CPU usage and doesn't change far from that number.

Using --debug-all command line argument shows the program freezes after CLEW Initialization Succeed.

I can't continue with Blender 2.8 since I'm relying on an addon that doesn't work on 2.8. So, how do I solve this problem?

  • OS: Windows 10 Home 64-bit
  • CPU: Intel Core i5-6200U @ 2.4GHz
  • GPU: AMD Radeon R5 M330, using latest Catalyst driver
  • Have you tried running Blender from command line using the --factory-startup switch? If that doesn't help, have you tried to rename your User Prefs directory in C:\Users\YOURUSERNAME\AppData\Roaming\Blender Foundation\Blender ? That would run Blender without any modified settings or Add-Ons, just to rule out some misconfiguration in your Blender settings. – aliasguru Oct 12 at 13:03
  • No doubt that is an issue with your graphics. I'm not even sure if blender supports the low end amd cards like that one. – David Oct 12 at 14:11
  • I already tried factory setup, fresh config, and none worked. – Rama Alifiandy Oct 12 at 14:36
  • Also Blender previously ran fine with R5 M330 – Rama Alifiandy Oct 12 at 14:36

Reinstalling the Windows (build 10586, with proper drivers installed) finally solves the problem and Blender runs fine, even the Cycle renderer works fine too.

I had no idea why that problem persists before reinstalling, because previously, I already tried troubleshooting by:

  • using --factory-setup argument
  • deleting Blender's AppData stuff
  • switching GPU driver versions back and forth
  • trying other versions of Blender (including nightly builds)
  • reinstalling Blender

...and aforementioned steps doesn't solve the problem for me.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.