3
$\begingroup$

I've been using Blender for years. This is my first time to experience it on a 2in1 PC (HP Pavilion x360). This machine has a pen which works perfectly in any app except Blender.

Whenever I tap the screen with the pen on a surface to paint (in UV/Image Editor or 3D View, no matter), it just doesn't start. When I drag the pen a little bit, then it starts drawing. Interestingly, the distance between the point I click and the point it starts drawing seems equal to length of the radius which appears in Win10 when holding pen to emulate right-click. I disabled holding option for right-click but the problem still exists. (This happens also when sculpting or painting weights.)

In Krita or GIMP, I don't experience this kind of issue. It just starts painting the moment I touch the stylus on screen.

I really want and prefer to use this pen in Blender rather than a mouse. How can I solve this problem? Can I decrease or totally disable required length of dragging that tells the system I'm not holding? (as I said disabling it in Control Panel doesn't work.) Or is there any way to make Win10 to treat Blender's window as in Krita's or GIMP's?

$\endgroup$
  • 1
    $\begingroup$ Same touch-draw distance problem for Grease Pencil in 2.79b on a Toshiba convertible with Wacom touch/pen (0x056A, 0x50A2, driver/utility 6.3.31-4 aka 7.3.4.48, wintab.dll 1.0.5.9) on Windows 10 Home build 17134. Disabling "Continuous Grab" has no effect. Tried disabling pen-related features as well, especially "Flicks" (Pen and Touch / Pen options / Pen actions / "Press and hold") "Hold to right click" Option, but no effect. Unfortunately, your solution does not fix it for me either. (same issue with Annotation in Blender 2.80.27 alpha) Anything else required (restart does not work either)? $\endgroup$ – handle Oct 28 '18 at 12:04
  • $\begingroup$ Could you please manually run "regedit" and go to "HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Pen" and then check if there's a 32-bit record named "LegacyPenInteractionModel" with value of "1"? Because this definitely disables that annoying threshold. It just may break the pressure sensitivity but that is another problem. It literally is the fix for "Windows 10 Fall Creator’s Update" which exactly is the cause of the problem. Also, make sure you have installed that update. Btw, can you tell me if you have Wacom drivers on your device? $\endgroup$ – mofselvi Oct 31 '18 at 20:22
  • $\begingroup$ It appears to have been fixed (works for me): developer.blender.org/T55589 (requires LegacyPenInteractionModel to be disabled). $\endgroup$ – handle Jan 26 at 1:29
  • $\begingroup$ @handle Happy to hear that! Two months ago, you said it didn't work. Could you please tell us more about what exactly solved your problem? Might be useful for anyone else having the same issue. $\endgroup$ – mofselvi Jan 27 at 21:00
  • $\begingroup$ I have the same problem, but unfortunately, the reg command does not apply to windows 10. Can someone give the windows 10 prompt line? $\endgroup$ – Cyril May 30 at 9:28
3
$\begingroup$

I'm back. Believe me or not I've been looking for a solution for weeks but I found a solution today just a few hours after I posted this question. So, now I'm sharing it:

Because of one of the updates, Win10 doesn't treat legacy apps and modern apps which specifically designed for pen in the same way anymore. I think this is why I have never faced any issue in many apps (such as Krita and GIMP) but Blender. (Blender is legacy but not GIMP? LOL I don't get it, too.) There is a way to disable this behavior.

Solution

  • Run cmd
  • Type this and enter: reg add HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Pen /v LegacyPenInteractionModel /t REG_DWORD /d 1 /f

This will make it! If you have any problem with pen in future and want to go back use this command: reg add HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Pen /v LegacyPenInteractionModel /t REG_DWORD /d 0 /f

Btw, yes... it really is a BIG mistake not to put an option for this in the control panel. I wanna swear to Microsoft but I don't know if it's allowed here. So... shame on you MS! It took me weeks to just find this solution.

[Source: https://www.reddit.com/r/Windowsink/comments/8508fi/controlling_pen_behavior_in_windows_10/ ]

Edit

Addition:

It seems this command breaks pressure sensitivity. I solved it as well:

  • Go back with second command I mentioned above
  • Run regedit and go to HKEY_CURRENT_USER\Software\Microsoft\Wisp\Touch, set PanningDisabled to 1.
  • If there still is any issue, install/repair WinTab (https://www.microsoft.com/en-us/download/details.aspx?id=49498 download and install Wintab_x32_1.0.0.20.zip or Wintab_x64_1.0.0.20.zip depending your system arch)
  • If it still occurs, go run first command again.

Now, I can draw without any latency and pressure sensitivity works perfectly!

$\endgroup$
0
$\begingroup$

For me on a Dell XPS 2-in-1, the problem went away when I turned of Flicks in the Pen settings in the control panel.

$\endgroup$
  • $\begingroup$ I assume you probably have not got Windows 10 Fall Creator’s Update yet due to your OEM or your OEM provides you another update. This problem is specifically related to this update. Before the update, everything was working great for me without having to fix anything. $\endgroup$ – mofselvi Jan 27 at 21:06
0
$\begingroup$

In blender go to Edit -> preferences -> Input -> Tablet and select "Windows Inc" under "Tablet API"

Now your pen should behave as set by the rules under pen in windows settings (means you have to turn of hold for rightclick there if you have not already)

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.