3
$\begingroup$

I wish I was joking. I have this skirt that I want to make it look more like a skirt using the cloth simulation thing but instead of pulling it downwards and giving it some folds, it pulls it upwards and is spiky. Using the cloth presets (silk, leather, etc) don't really change anything. I tried erasing the weight paint at the top and it still didn't work. I'm wondering if some of the settings I used is making it this way?

EDIT: Added screenshots of the geometry

the skirt

cloth physics settings

enter image description here

geometry

enter image description here

$\endgroup$
  • 3
    $\begingroup$ Most likely you have intersecting geometry at the start of the simulation or vert close vertices within the cloth that are repelling each other with the self collision. Can you share some images of your geometry in wireframe or Edit mode? $\endgroup$ – Rich Sedman Oct 6 '18 at 13:52
  • $\begingroup$ i added the screenshots! $\endgroup$ – NoneType Oct 6 '18 at 13:56
  • 1
    $\begingroup$ Thanks. Try switching off Self Collision. If this doesn't help then scale up the mesh so it's definitely not intersecting with the model at the start of the simulation. You could also try reducing the cloth Speed Multiplier back down to one (it will produce a more stable simulation). There's a Self Collision Vertex Group that lets you exclude certain vertices from the 'self collision' group - it's a good idea to set that to the same as your 'Pinning' group. Could also try resetting all the cloth settings back to the defaults (those when you first add the cloth sim). Try changing one at a time. $\endgroup$ – Rich Sedman Oct 6 '18 at 14:53
  • $\begingroup$ ah, it worked! the skirt itself was colliding with the model at the start, so i'm assuming that was what made it all weird. I'm very new to this, so thank you for the help! $\endgroup$ – NoneType Oct 6 '18 at 15:07
  • $\begingroup$ No worries - glad to help and glad it’s now working. I’ve added an answer. $\endgroup$ – Rich Sedman Oct 6 '18 at 15:25
3
$\begingroup$

For cloth collision (and, indeed, any collision in Blender) it is important to ensure that the simulation starts without the meshes overlapping - otherwise they will instantly repel and can cause unpredicted results.

With cloth, if the ‘garments’ are intended to be quite tightly fitting you can use sewing springs or cloth shrinking to bring the garment together around the model once the simulation starts. Those options are found within the Cloth Sewing Springs panel.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.