I have a NVIDIA RTX 2080. I've got an error like this:

CUDA binary kernel for this graphics card compute capability (7.5) not found.

Does someone know how to enable it?


6 Answers 6


You cannot enable it since it is not yet supported. You will need to wait until it is, or attempt to build Blender with the support for Cuda 10 yourself apparently.


Update as of July 29th 2019: NVIDIA RTX GPUs are now officially supported and can be used to accelerate renderings in Cycles using the raytracing cores of RTX cards. You can read more about this from the Blender Developers blog here.

In the past, RTX GPUs were not supported even for normal use cases unless you compile Blender from source code yourself or download a pre-compiled version of Blender 2.79 (link below) for Linux. However, if you want the latest features/bug fixes you need to compile Blender from source still. People have compiled Blender this way and submitted their results to Blender OpenData too. As shown on Blender OpenData website, RTX 2080 Ti is currently the best GPU for rendering scenes with Cycles as of now.

If you're using Windows you can follow these instructions to compile Blender yourself:

Install Development Tools

Subversion, Git, CMake and Visual Studio must all be installed.

Download Sources and Libraries

Create a folder to store your copy of the Blender source code. This guide will assume your chosen folder is C:\blender-git.

Then open the command prompt window by hitting Windows+R, and then typing cmd, or by searching for it in the start menu. Then type the following commands.

For 64-bit Windows, check out the precompiled libraries with Subversion like this:

cd C:\blender-git
svn checkout https://svn.blender.org/svnroot/bf-blender/trunk/lib/win64_vc14  lib/win64_vc14

For 32-bit Windows, use this command instead:

cd C:\blender-git
svn checkout https://svn.blender.org/svnroot/bf-blender/trunk/lib/windows_vc14  lib/windows_vc14

Download the Blender source code:

cd C:\blender-git
git clone git://git.blender.org/blender.git
cd blender
git submodule update --init --recursive
git submodule foreach git checkout master
git submodule foreach git pull --rebase origin master

Compile Blender

cd C:\blender-git\blender
make full

Source for the things above. In case you follow these steps and you still cannot get Cycles render anything using your RTX card, you need to follow the steps at the end of my post to rebuild/recompile Blender.

For Linux:

If you're on a Unix-based OS you can follow the instructions written here; Make sure you have installed CUDA 10 already. If you don't want to compile Blender yourself, you can instead download a version of Blender 2.79 compiled against CUDA 10 from here.

Update as of Dec 3rd 2018:

As of today, the master branch of Blender natively supports NVIDIA RTX cards. So you don't have to follow the steps below anymore.

In case you follow the above steps and still cannot render anything using your RTX card, you need to do the followings to recompile Blender. This step works for Windows, Linux and Mac:

  • Open CMakeCache.txt
  • Add sm_75 to that list
  • Rebuild/Recompile Blender
  • 3
    $\begingroup$ It is a bit different with RTX. They are different from GTX. Support requires more than simply re-compiling. It would be already done if that was so simple. I am afraid this might not work. $\endgroup$ Oct 5, 2018 at 11:44
  • $\begingroup$ @MartinZ The Blender developers have already added support for RTX cards as you can see here . $\endgroup$
    – Amir
    Oct 5, 2018 at 12:05
  • $\begingroup$ So that's only Cuda 10. I guess it might work. I still think there is a good chance it will not, or have you actually tried it? The full support will be trickier since there are new hardware functions in the card. It is not that straight forward - to use them additional work will need to be done. But the future is looking bright: twitter.com/tonroosendaal/status/1029752422485254144 $\endgroup$ Oct 5, 2018 at 12:42
  • 1
    $\begingroup$ @MartinZ No I didn't try it myself but some others have tried and it looks like things work fine now. I'm afraid your confusion is on on full integration of NVIDIA OptiX in Blender. What I can tell you is Blender will not support OptiX for a while (maybe about a year from now). So the raytracing capabilities of RTX cards won't be used in Blender but you can certainly use the cards to do normal rendering in Cycles. $\endgroup$
    – Amir
    Oct 5, 2018 at 13:11
  • 2
    $\begingroup$ @amir not sure what do you mean with "the developers added support", still I cannot use the GPU (RTX 2080) to render or viewport - downloaded latest night build! "CUDA binary kernel for this graphics card compute capability (7.5) not found." I am not talking about Optix! - Did anyone try to compile that on Win10? $\endgroup$
    – user63248
    Oct 9, 2018 at 10:13

I have an NVIDIA RTX 2080 card and I had a long time to get it to work to do rendering with it. But the solution seems to be simple: all you need is to download the Linux version (from the previous answer http://graphicall.org/1241/download), copy the folder "lib" from the downloaded file" (I have this looks so)

(C:\Program Files\Blender Foundation\blender-2.79-cuda 10-x86_64 (linux)\2.79\scripts\addons\cycles)

and paste it in the program folder

(C:\Program Files\Blender Foundation\blender 2.79.0\2.79\scripts\addons\cycles\lib)

  • 2
    $\begingroup$ Thanks. This worked for me. For reference, BMW rendered on a 2080ti stock at 59 seconds $\endgroup$
    – Shaun
    Oct 20, 2018 at 22:20
  • $\begingroup$ Freaky fast!!!!! $\endgroup$
    – Jan Matys
    Oct 24, 2018 at 15:38
  • 1
    $\begingroup$ @Shaun This is because things are constantly changing in Blender and the stuff in scripts\addons\cycles in the pre-compiled version of Blender 2.79 doesn't necessarily match with the stuff in the latest versions of Blender. You need to compile Blender from source so that things work smoothly as I mentioned above :) $\endgroup$
    – Amir
    Oct 26, 2018 at 14:05

Found and fixed this by following the advice of one of the blender contributors here: https://blenderartists.org/t/nvidia-unveils-new-turing-architecture/1122494/105

scroll down to lazy dodo's comments from september 23 - essentially you have compile yourself and make a few edits to the makefiles.

I can confirm this works.

Tried as well. Make sure you use the 'make release' compilation command. However, while I can get the 2080ti to appear, I can't get the 2080ti to actually make anything (same error as precompiled nightly.)


I have managed to get this working on my RTX 2080ti on Windows by downloading the latest experimental build (2.80 alpha 2 at time of writing).

These are available here: https://builder.blender.org/download/


You have to download Blender 2.79.6 or 2.80(beta) LINK: https://builder.blender.org/download/


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .