Every time I try to texture paint a character it messes up in some way. Ive tried multiple unwrapping methods but every time the paint will bleed over into other parts or wont paint at all and ill get seems

Right here all I did was air brushed the hand and it shot right over to the chest area. The UV islands are no where near each other. It makes it impossible to work with



It is difficult to tell without the actual Blender file, but in the image provided, some of your UV islands are in fact overlapping and others are quite close together.

Overlapping UVs

To fix this, select all of the faces in edit mode and then, with your cursor over the UV window, hit Ctrl + P. This will automatically arrange the UV islands. In the 3D viewport window, in the tools panel (far left of the image), you can then set a margin, which you'll want to avoid this bleeding.

Pack UV islands, set margin

Additionally, you can set the bleed amount option in Texture Paint Mode to 0px, but this may cause problems later on. Especially if you want to use a subdivision surface modifier on the model.


  • $\begingroup$ But look, I painted one line only on the side of the body but then it also over lapped onto the back side, the islands are on the other side of the texture. Nothing is over lapping. Its like this all over the place. i.imgur.com/xhwNGQU.png $\endgroup$ – Sic Oct 5 '18 at 3:03
  • 1
    $\begingroup$ In that case I'd suggest looking at the the "Occlude", "Cull", and "Normal" settings in the panel shown in my third image. Alternatively, you could enable "Face selection for mask painting" (the button with the semi-texture cube on it on the bar where you can select your mode and shading) and then select the specific faces you want to paint. $\endgroup$ – BlenderBro Oct 5 '18 at 4:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.