1
$\begingroup$

I've disabled all objects except the camera and hit F12 to do a quick render.

Blender takes 45 seconds just to draw a blue screen.

In my user preferences my 2011 GeForce card is enabled.

Why so long? How do I improve this please?

enter image description here

If this information helps, maybe some other setting is wrong, because my Cycles Renderer looks fine in the 3D window:

enter image description here

but my Blender Renderer looks completely wrong, turning my green hairy plane orange. And when trying to F12 with it it just draws a grey screen instantly with no world background color.

enter image description here

--

UPDATE:

I've done all these tips to bring down render speed:

  • in render options - light paths set bounces from 0 to 4
  • change dimension - resolution - to 50%
  • performance - change tile size to 256
  • shading - disable ray tracing
  • world - disable ambient occlusion
  • light paths - disable shadows
  • render - sampling - reduce to 8 from 128

That takes rendering nothing from 45 seconds to 5 seconds. But I want it to be almost instant. I have to render an animation that's thousands of frames long and it's just a simple cube moving across the screen.

I tried making a similar animation in three.js and it draws things pretty much instantly in real time in my web browser. I don't understand why Blender is being so slow :(

$\endgroup$
  • 1
    $\begingroup$ Interesting question, a few seconds would be OK but 45 sec. is way too much. Do you mind to share your Blender file in order to take a look on it? $\endgroup$ – Yann Masoch Oct 3 '18 at 20:16
  • $\begingroup$ Thanks! Here: we.tl/t-aq9ZzayleM (I'm not sure why the file is 30 MB either, I just have a couple primitive objects in my scene) $\endgroup$ – Richard Oct 3 '18 at 20:23
  • 1
    $\begingroup$ Thanks for the file. I did some tests and checked your render settings - nothing seems wrong. A the first try, I got some issues for rendering the scene and the render took a lot of time. But after reopening the file everything was fine (the "empty" render takes ~4s on my computer using a GTX 1070). Try to change some settings such as the "Tile size" in Render>Performance to see if things come back to normal. Let me know! $\endgroup$ – Yann Masoch Oct 3 '18 at 21:13
  • 1
    $\begingroup$ I guess this answers my question somewhat: quora.com/… $\endgroup$ – Richard Oct 3 '18 at 21:42
  • $\begingroup$ Render nothing always takes a bit of time and it's never equal to 0s, especially using cycle. Three,js displays graphics in real-time like your Blender 3D viewport.. $\endgroup$ – Yann Masoch Oct 3 '18 at 21:43
3
$\begingroup$

It is not a big surprise.

This is the time it takes to render nothing on an old i7 2600K processor:

enter image description here

And this is the time it takes to render the same nothing on the same old i7 2600K processor 2048 times(2048 samples):

enter image description here

Cycles is not very adaptive. It does not care much that it is the same plain color you ask to be sampled 128 times. It will do precisely that. This is pretty normal. The GPU you are using might not be a very powerfull solution for rendering. You could try CPU rendering as well see if that is any better with the CPU you have.

If you need simple results, you could also look into OpenGL rendering. That will render whatever you see in the viewport. It has a few settings so you could use better antialiasing as well.

enter image description here

$\endgroup$
  • $\begingroup$ Thanks. And any idea why the Blender Renderer is drawing things orange? I've read it's more simple and fast so I might want to try rendering with that if I can fix it. $\endgroup$ – Richard Oct 3 '18 at 21:29
  • $\begingroup$ I do not use Blender Render myself so I cannot provide detailed help with it, however I assume you just need to set up the materials and light for it correctly. $\endgroup$ – Martynas Žiemys Oct 3 '18 at 21:36
  • $\begingroup$ Great answer, you captured it perfectly. Richard you might want to keep in mind that with Eevvee and Blender 2.8 releasing soon, that will lighten the load a lot, especially for long animations imo $\endgroup$ – Dr. Farquaad Oct 3 '18 at 21:43
  • $\begingroup$ Yep. EEVEE will be great for that. Not only that, but it will be a lot easier to render with OpenGL in 2.8. It is still quite unstable and full of bugs at the moment however. $\endgroup$ – Martynas Žiemys Oct 3 '18 at 21:53
0
$\begingroup$

The Cycles renderer does ray tracing and thus takes ages to calculate every frame. See here: https://gamedev.stackexchange.com/questions/136757/how-do-modern-game-engines-achieve-real-time-rendering-vs-blenders-slow-rende#answer-136776

If you're using Blender before 2.8 then use the Internal Render engine, it's MUCH faster than the Cycles Render engine.

If you're using Blender 2.8 or after then use the EEVEE Render engine.

This alone should fix the problem, reducing your renders to near instant.

You're getting funny colors on your objects because when you switch between Cycles and Internal you have to reassign all your materials - each engine has different materials that aren't compatible with the other renderer.

If you want to use Cycles for some reason then you can improve render times a bit by trying:

  • in render options - light paths set bounces from 0 to 4
  • change dimension - resolution - to 50%
  • performance - change tile size to 256 (16 for cpu only with no gpu)
  • shading - disable ray tracing
  • world - disable ambient occlusion
  • scene - simplify
  • light paths - disable shadows
  • render - sampling - reduce to 8 from 128
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.