Here is my problem, I need to create 2D aspect animation from 3D model in blender. From the start my rended image is okenter image description here

But when I transform it, I need to use the Shadow Pass and it looks realy blocky ! Need some help please :) enter image description here

  • $\begingroup$ Which render engine did you use? $\endgroup$ – quiliup Oct 3 '18 at 21:16

The reason for jagged shadows lies in the technique used for rendering the shadows. I assume you used the blender internal render engine and the standard shadow of the lamp; for spots lamps the default is the buffered shadow.

Here is a rough explanation how buffer shadows are calculated

With buffer shadows something like a render is made from the view of the light source lamp. Every surface point not visible on this lamp-rendered image isn't reachable by this light source. Thus, these pixels of the lamp-rendered image projected to the unreachable surfaces will be a good approximation of the shadow in the final render. According to this the blockyness depends on the resolution of this lamp-rendered image. It can be adjusted at the lamp settings:

enlarging the buffer size

Here is more info on how the buffering works.

So increasing the size is the solution?

No. A better way is to change the shadow rendering technique. The other one available in blender internal is Ray Shadow which probably is the best solution. change to Ray shadow

I hope your shadow pass is blockless with this method now :)


enter image description here

It's ok, I have solved this problem using Diffuse too !


We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

  • 3
    $\begingroup$ Hi. Please add some extra information as to how you specifically solved this. At the moment this answer doesn't give much information. $\endgroup$ – Ray Mairlot Oct 3 '18 at 14:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.