1
$\begingroup$

I am running Ubuntu 18.04 on a fairly powerful PC (Ryzen 2700x and Vega64) I finally managed to get OpenCL to work at all with ROCm-rehl drivers.

When I render the default cube scene CPU rendering takes 7 seconds while GPU rendering takes crazy 40 seconds. both are compared using one 512*512 tile.

Also I can't really hear my GPU fans revving up as I can with my CPU fan when rendering on CPU.

$\endgroup$
  • $\begingroup$ Try a more complex scene (or increase samples to something like 1M). GPU rendering might have A LOT of overhead/initialisation cost. This is where most of the "render time" is going, especially on the very first render. This is why most blender benchmarks are NOT done with the default cube.blender.org/download/demo-files $\endgroup$ – miceterminator Oct 2 '18 at 7:59
  • $\begingroup$ With anything more complex it hangs on "loading render kernels - this may take a while" and then nothing happens. $\endgroup$ – Captain Katawa Oct 2 '18 at 8:11
  • $\begingroup$ ^- should probably be your question. Originally it said "may take a few minutes" I suggest you try that and report back. Also watch your ram usage (systemmonitor/htop/glances) $\endgroup$ – miceterminator Oct 2 '18 at 8:18
  • $\begingroup$ Cpu usage stays at 6%, memory usage 600MB and mothing happens for a long time. I useb Blender on windows and there loading kernels takes a few seconds and then it renders fast. $\endgroup$ – Captain Katawa Oct 2 '18 at 8:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.