0
$\begingroup$

as you can see the particles are completely ignoring the wall to the left and they all go straight through

enter image description here

the floor also is a collision object but it has no problems as the particles hit the floor and slide across. i checked the normal directions of the wall, tried baking the rigid body cache, gave them the same settings, changed the shape of the rigid body but to no avail. keep in mind the particles has the size deflect checked as it still works for the floor. i dont understand what is causing this.

$\endgroup$
  • $\begingroup$ I think your walls are too thin, but I did try increasing the solver steps per second and the solver iterations and it made little difference. The best solution appears to be to add thick invisible collision passive walls around the object. $\endgroup$ – rob Oct 1 '18 at 11:11
  • $\begingroup$ even that didnt help $\endgroup$ – whydoiexistmate Oct 1 '18 at 17:51
  • $\begingroup$ It does seem the problem is the particles are moving too quickly for the solver to determine the collision. What is if you try really really thick walls? I wonder if there is a option of creating a slower explosion so the solver can work and then either increasing the frames per second or removing the Nth frame. $\endgroup$ – rob Oct 2 '18 at 7:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.