0
$\begingroup$

this is my object mode and my node editor screen also

so as i was following a tutorial on blender guru (youtube channel) when i added the normal map to my wood texture , this happen !!! when i render every thing is okay and it's beautiful but it's annoying me so much when editing and modeling i see the normal map , why is that's happening !? i tried to replace the images again or tweak the options , but none work , can you help me please !?

$\endgroup$
  • $\begingroup$ As you enabled Texture shading mode, Blender shows you currently selected texture in the Node editor. Enable Solid shading mode and it will show solid grey colors. This affects only viewport $\endgroup$ – Mr Zak Sep 29 '18 at 13:43
2
$\begingroup$

It's happening like that because you have selected the normal map image node in the Node Editor. If you click the object texture node in the node editor, that active node will be displayed in the viewport.

EDIT:enter image description here

$\endgroup$
  • $\begingroup$ But even when I close the node editor it's still there , and when I click the texture image it appears in view port so how to deactivate it ? $\endgroup$ – Hassan elkashif Sep 29 '18 at 13:23
  • $\begingroup$ You should click on the node which contains your image texture. $\endgroup$ – AshKB Sep 29 '18 at 13:26
  • $\begingroup$ I did that but instead of my normal map is in the viewport , my wood image texture is in the viewport , I only want to see my plate white and gray object like the cup and the donnate !! $\endgroup$ – Hassan elkashif Sep 29 '18 at 13:31
  • $\begingroup$ I've updated my answer. If it solves your problem, mark the answer as Accepted. $\endgroup$ – AshKB Sep 29 '18 at 13:42
  • $\begingroup$ That's what I did in my gif at last :) $\endgroup$ – AshKB Sep 29 '18 at 13:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.