0
$\begingroup$

With the plane i have converted to curve. And made the profile i bevel the curve is getting twisted.

As we have XYZ axis. Where this W axis came from

enter image description here

enter image description here

With the Tilt option i can rotate but why its twisted.

enter image description here

$\endgroup$
4
$\begingroup$

1) If you first apply the rotation to mesh-plane and converts into a curve then generally this problem happens. So, if you only need a rectangular curve object, then the best way to ADD a curve-circle > EDIT mode > Press V > set handle type to 'Vector', you have rectangular curve object.

Now the twist problem:-

2) For circular curve or curve having smooth bends: Go to Curve properties panel, then change the 'twisting' option from 'minimum' (which is default) to 'tangent' and for a curve having smooth bends, also adjust the 'smooth' option accordingly. (Note- Spline Type should be 'bezier')

When the 'twisting' is set to 'minimum' : enter image description here

When the 'twisting' is set to 'tangent' : enter image description here

3) For rectangular curve :

(a) Rectangular curve from curve-circle: ADD a curve-circle > EDIT mode > Press V, set handle type to 'Vector' > then again Press V set handle type to 'Free', then go to Curve properties panel, then set 'twisting' option to 'minimum' and 'smooth' to 50 (adjust accordingly). In this way you have a twist free curve even if you move curve-points in the edit-mode and movement of curve-points only shift the overall tilt of the curve. (Note- Spline Type should be 'bezier')

enter image description here

(b) Rectangular curve from mesh-plane: If you convert mesh-plane to curve object and it has Spline-Type 'poly', therefore twisting option does not work properly. So, go to Edit Mode > Tools > Curve Tools > Set Spline Type to 'Bezier' > Press V, set handle type to 'Vector' > then again Press V set handle type to 'Free'. Then go to Curve properties panel, then set 'twisting' option to 'minimum' and 'smooth' to 50 (adjust accordingly). (Note- Spline Type should be 'bezier') enter image description here

$\endgroup$
  • $\begingroup$ Thanks for the detail answer. But when i tried with my plane converting and change to tangent and tweak smooth setting did not get the result. Can you plz experiment on my plan and show me in .gif recorded way. $\endgroup$ – atek Sep 30 '18 at 3:12
  • $\begingroup$ @atek I have updated my answer and as I mentioned in the answer, 'tangent' option works nicely for circular curves and 'minimum' for rectangular curves. For mesh-plane, see '(b) Rectangular curve from mesh-plane' in my answer. $\endgroup$ – 3DSinghVFX Sep 30 '18 at 12:18
  • $\begingroup$ This is the result im getting according to your steps. imgur.com/gallery/fs5a1N4 $\endgroup$ – atek Sep 30 '18 at 13:44
  • $\begingroup$ @atek I used your blend file and found that after doing all steps, go to EDIT mode > select all the points > rotate them along-x by a very small angle ~ 0.001, that fixes the problem. Can you send me/upload the blend file which has the problem as you mentioned in comment ? $\endgroup$ – 3DSinghVFX Sep 30 '18 at 15:19
  • $\begingroup$ Did not work for me. And the file i have upload in the question its same im getting the result. I rotated also but did not work $\endgroup$ – atek Sep 30 '18 at 15:53
0
$\begingroup$

I don't know how to properly set (or reset) the tilt of those control points, being that curve converted from a square mesh.

But if you wish to get that shape, try using a bezier circle, set its control point as "vector", they will behave much better, and probably you'll get what you want:

enter image description here

enter image description here

enter image description here

enter image description here

$\endgroup$
  • $\begingroup$ I tried to reset pressing Alt+T did not work. $\endgroup$ – atek Sep 30 '18 at 3:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.