0
$\begingroup$

I have a test scene to render for stereo VR on YouTube. They suggest 5120x2560, and you get stereo stacked Top-Bottom. I have set the settings so it renders in 2 minutes at 25% and then also reasonable about 10 minutes at 50%. If I go to 100% the GPU does nothing and it slows to an unknown maybe 15 hours or let's argue 8 hour render, same settings. I guess my GeForce GTX 780 Ti has a limit of some kind so it dumps it out to CPU only I'm assuming. There are no textures in the test just one for Environment lighting. Around 200K Verts and Faces with Tris double that.

I also tried 75% which guesses about 2 hours but I think maybe that's per eye, so even at 3840x1920 it seems to stop being able to use the GPU efficiently. I have tried larger Tile sizes to no effect currently 256x256

I think maybe the Cycles Rendering pipeline is not able to split the work when the card can't keep up. It could maybe stitch together multiple renders automatically. Like I must have foolishly assumed tiling does. Obviously in this case we don't have a Mem Fault, which culling could be another level of rendering more efficiently. I kind of realize the irony that Eevee will do it instantly or something hopefully (but I've not investigated it since it's still not officially available).

Any insight here would be appreciated. Otherwise maybe this needs to be reported as a bug or something? I'm still confused what's wrong is there a way to check that this is going to happen (render-crawl) other then looking at estimate render time progress?

Mem is only Peaking under 700M normally 330M at 75%

Normally I render at 4000x4000 without any issues.

$\endgroup$
  • $\begingroup$ I decided to break the view into pieces just to test. Being Stereo Panoramic Equirectangular I simply set the Min Max Longitude to provide 4 quarter slices. Super lame Hack with Multiple Scenes with Multiple Cameras and a Scene for Compositing that just uses the Output File Node. Unfortunately it errors and stops after the first frame with this error... imb_savepng: Cannot open file for writing: '0001.png' 0001.png: Permission denied Error: Render error (Permission denied) cannot save: '0001.png' This is not even the filename it should be using. Let's call it disabled garbage for now. $\endgroup$ – Master James Sep 30 '18 at 5:08
  • $\begingroup$ Seems in the Empty Scene for Compositing that calls the Camera Scenes requires something other then blank in the Regular Output for the filename. I've put something in there but you get a black file so there's no frame reference and maybe no overwrite will work etc. I tried comping the pieces into one file within Blender but that too seemed to have too many problems and not work in the end, so I'll suggest Natron for building the pieces back to a single stereo file. $\endgroup$ – Master James Sep 30 '18 at 7:10
  • $\begingroup$ So there a bug in that. If there is an empty filename Blender should not try to write out to it?! You can also use that first scene for one of the files as normal and add the other scenes in a compositor node tree and not have a dedicated render comp scene but that seems confusing not having them together, so another hacky solution to help wade through the limitation and bugs. $\endgroup$ – Master James Sep 30 '18 at 7:14
  • $\begingroup$ Next I realized that even baked dynamics can't be reliable copied to another scene, so I built duplicate files and resorted to batch files. Unfortunately only the first frame has color, all others are nearly black, so now I'm looking at the idea of multiviews? blender.stackexchange.com/questions/102060/… except I've already got Left and Right for Stereo set up. $\endgroup$ – Master James Oct 1 '18 at 2:03
  • $\begingroup$ Actually all forms of CLI batch rendering with any possible arguments -a, -f, -s & -e (--frame-start --frame-end) will only render the first frames. All following frames are near black but not actually black. With Blender open it is working as expected. using no -b (aka GUI Blind) so the interface launches results in a grey box with no GUI that crashes. if you don't run from the Blender path it does not load the GUI, but it still fails to render. $\endgroup$ – Master James Oct 1 '18 at 3:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.