1
$\begingroup$

I have a problem when I try to mirror my run animation, the IK bones on the foot go completely out of control on the mirrored portion of my animation.

The white keyframes are what I copied, and the yellow are the keyframes are the ones I pasted with (shift ctrl V)

enter image description here

enter image description here

The IK bones go completely out of control in the mirrored portion of the animation.

I used sebastian lague's amazing rigging video

https://www.youtube.com/watch?v=Q9f-WVs3ghI

$\endgroup$
1
$\begingroup$

After take a look into your Blender's file. I think that your problem is about your Leg Control bones aren't have the same local rotation in edit mode. So whenever you do mirror paste, your bone will move at wrong direction.
How to fix it:

  1. Select your armature then press TAB to enter Edit Mode
  2. Select both of your Leg Control bones then press CTRL + N and choose Global + Z Axis Picture 1
  3. Back to Pose Mode and do your mirror paste, the rig is working perfectly now.
    enter image description here

P/S: You must re-animate your animation, because after reset rotation, your armature doesn't work correctly with current animation. Here is your file after i fix it. Sorry about my bad english, hope someone could edit this :(

$\endgroup$
  • $\begingroup$ You are a life saver thank you very much. and your English is just fine :) $\endgroup$ – Hotpockets26 Sep 29 '18 at 18:15
  • $\begingroup$ You're welcome. $\endgroup$ – Ryo Oct 1 '18 at 3:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.