2
$\begingroup$

We recently switched to Windows 10 in our lab at school. Since the switch we can't get rotation to work normally in Blender. We have tried 2.79, 2.79b, and 2.78c and all behave the same.

When we try to rotate using the transform manipulators, the object always rotates around the z axis. Even if we try to change the rotation axis constraints, it switches back to a z-axis constraint.

Any ideas? We have used Blender for a long time and not had this problem. What are we doing wrong?

Video of the problem: https://youtu.be/MTEIR5Enu6Y

$\endgroup$
  • $\begingroup$ try using the r key and pressing x/y/z (an axis), and see what happens $\endgroup$ – Dragion Tech Sep 25 '18 at 19:51
  • $\begingroup$ Those work, but we used to be able to rotate by dragging the manipulators. Has that function been removed? We are using Blender with younger students, and it would be nice to use the manipulators. $\endgroup$ – user2380187 Sep 25 '18 at 19:54
  • $\begingroup$ Try looking into this thread blenderartists.org/t/issues-selecting-the-3d-manipulator-arrows/…, it mentions multiple solutions for different cases, (changing 3d settings for Blender in graphic card software, picking desired graphic card for Blender if multiple are present, settings in User Prefs > System etc.), maybe one of them can help. This problem seems to be dependant on hardware + software configuration. If nothing works in the end with newest stable releases submit a bug to developer.blender.org/maniphest/task/edit/form/2 with all details included $\endgroup$ – Mr Zak Sep 27 '18 at 14:47
  • $\begingroup$ The system uses internal Intel Graphics 630. I tried all kinds of different settings in the Intel HD Graphics control panel trying to get it to work. I also tried all kinds of settings in the Blender User Preferences. I guess the next step is a bug report. We can't afford to put graphics cards in all the machines, though I suspect that would instantly solve the problem. $\endgroup$ – user2380187 Nov 16 '18 at 21:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.