I would like to know why,even if I have removed all the keyframes added by a BVH file AND after resetting the pose with ALT + R ; ALT + S ; ALT + G,in object mode and in pose mode the 3d character is not aligned to the world origin,but in edit mode it is. What can I do to fix it ? Thanks.

character before resetting the pose

character in pose mode after resetting the pose

character in edit mode after resetting the pose

character in object mode after resetting the pose

This is what happened when I have removed the armature modifier from the mesh :

armature removed

....when I move the mesh,the armature is still attached to it....


1 Answer 1


This is common with BVH files. There is a great app called bHacker which was created to solve these kinds of things.


What you need to do is basically reset the origin on the BVH file so that the feet rest on the ground and the reprocess the animation by saving it out. It has been a number of years since I had to do this, so I don't remember the exact steps.

Luckiy I wrote a tutorial about this for 3D Artist Magazine back then and I think most of the steps are there.


The issue is that even if you "apply pose to rest pose" in Blender it will just put the animation to that degree above the ground, which is not what you want. You could theoretically use some kind of workaround in Blender using NLA layers and rebake the animation to the ground after resetting the rest pose. So if BVHacker does not work, that would be the second best option. But NLA Layers can be very tricky to work with. It would require making an additive layer and animate the root bone down through the whole animation, and bake.

BVHacker is a much more elegant solution.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.