I was experimenting with a file in 2.8 and as habit of saving I saved the file. When I opened it back in 2.79 I can't see my model. It disappeared with the error " File written by newer Blender binary".

How can I get my model? I can see my model in 2.8 but nothing in 2.79. I tried to export it in .obj, but I lost all my modifiers, material and camera setting.

blender error message

up vote 9 down vote accepted

Restore your file from a backup. Check whether there is still a .blend1 or .blend2 next to your .blend, or pick a backup from another source.

If you didn't make backups before using a Blender 2.80 beta, you'll probably have to manually restore by trying to copy-paste bits and pieces between 2.80 and 2.79.

Note that the download page said Do not use in production nor save important files with it for a good reason.

  • Its giving error widows cannot open the file imgur.com/gallery/D70Xk7a and when i select the program i cant find blender in that program list. – atek Sep 25 at 8:29
  • 1
    Just rename it to .blend or open the file directly from Blender. – dr. Sybren Sep 25 at 9:04
  • i cant find the .blend1 file in the open file directly from blender – atek Sep 25 at 12:05
  • 2
    Disable the "filtering of files" button in the file browser. – dr. Sybren Sep 25 at 22:14

I find the easiest way to get an object back into 2.79 is to append the object. After starting 2.79 (a new file not after opening the 2.80 file), choose File->Append and select the object from the 2.80 file, this brings in the object, modifiers, mesh data, materials and animation.

Directly opening a 2.80 file with 2.79 fails to read object data, you will find the mesh, materials and action data is there.

After opening a 2.80 file in 2.79, add a new object, in the mesh properties change its mesh data to use the original mesh data. Materials are usually associated with the mesh, but if not you can find the material in the materials list. If you go to the action editor (mode of the dopesheet) you can also select the action associated with the original object. Actual object data will be lost, such as modifiers.

mesh data

As most addons are not working yet, we only have two export options in 2.80, collada and alembic. Both can export data that can then be imported in 2.79, when exporting you want to make sure modifiers are not applied so that you can re-create them.

If you can still see your model in 2.8 you should be able to just append it over to your 2.79 file by opening it (in 2.79) and appending it as an object from the 2.8 version file.

  • I tried it. Nothing is appended – atek Sep 25 at 8:23

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.