I have an issue with rendering my wood texture.

It shows up fine in render preview but not in the final render: the texture shows up black.

**Here the final render**

I'm not sure if it's my render settings or the way I set up my texture in the node network and I did UV unwrap of the plane.

It'll be helpful if someone could help me through the steps

  • $\begingroup$ Thank you for responding to my ask but yesterday I finally found out what was the problem the outline render button was turned off so it wasn't showing my texture but I don't remember touching it all I did was renamed my objects sorry for wasting your time $\endgroup$ – Andrea Monnar Sep 24 '18 at 15:26

I am reasonably sure, that the wooden "table" is set to not visible in the final render. In the Object outliner scroll down and check if the camera symbol for "restrict rendering" (rightmost symbol in the outliner) is checked/unchecked on the object with the wooden texture.

check in the wiki page under "Toggling object-level restrictions"


Also check

Why does my object not show up?

Render result is completely blank?

enter image description here

  • $\begingroup$ your photo-superposition makes it clear that you are right: the object is absent from the render, not incorrectly shaded (as my answer suggests). I'll leave my answer in case that's the actual situation with other users $\endgroup$ – Nicola Sap Sep 23 '18 at 9:46

I'm not sure if that is the reason of your black render, but if you have UV unwrapped the table, your node setup should include the UV texture coordinates (in most cases Blender will figure this out itself, but not if there are possible ambiguities, like more than one UV maps):

enter image description here

Add Node > Input > UVMap; select the UVMap – you probably have only one – and connect to all the "Vector" sockets of your textures.

Then select the correct one in the "Normal Map" node too.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.