0
$\begingroup$

Im really wondering why the MantaFlow branch does NOT show me anything. What I mean ... I made a simple cube as a domain, than another one as an obstacle and finally a sphere as a flow. Leave the settings as it is but of course change the type of simulation to liquid for both the domain and flow. When I press "play" on timeline nothing happens so I tried to press "bake" which looks like something is computing cause it takes some time. After all is done I want to play the anim but I still see NOTHING so wonder if I made some mistake or what??? If someone could point me in the right direction I will be REALLY glad fellas!

Sincerely, Jan

$\endgroup$
  • $\begingroup$ Please show some screen captures so it is easier to understand your Blender Scene. Have you rendered many other scenes in Blender before your experience in MantaFlow? I also suggest tutorial for MantaFlow probably on the famous video site. $\endgroup$ – atomicbezierslinger Sep 22 '18 at 0:46
  • $\begingroup$ In Blender Fluid simulation you must also save your file prior to [bake] $\endgroup$ – atomicbezierslinger Sep 22 '18 at 0:53
  • $\begingroup$ Hi mate, THX for reply ... its past 3am here in Czech so I will reply soon after wake-up buddy. In a meantime could U please point me out (link) on some fully working branch U use so I could be sure about it? Im using Win7 btw $\endgroup$ – Jan Matys Sep 22 '18 at 1:19
  • $\begingroup$ I think you should believe this is a simple error, which you can remove. I would use graphicall.org. I use blender integrated fluid simulation. Perhaps in days I can perform some test but not in the next 24 hours. $\endgroup$ – atomicbezierslinger Sep 22 '18 at 1:24
  • $\begingroup$ I will send U some screens later today. In fact I saved the project and during the bakeing proccess I found a "fluid_cache" folder so it saves some data but shows nothing when try to play the anim/simul. $\endgroup$ – Jan Matys Sep 22 '18 at 1:35
3
$\begingroup$

The mantaflow branch works a bit differently than you may expect. First bake the fluid sim, then enable fluid mesh and bake the mesh. There is no visible mesh changes before baking the mesh.

You can pause the bake after a few % and start the mesh bake to see results at the beginning before finishing the bake.

There is also fluid particles that can be baked, this can give the extras like bubbles floating on the surface.

mantaflow bake settings

$\endgroup$
  • $\begingroup$ Hi mate, in fact I found this release: blender-2.79a-908dbed-win64 ...which looks like there is nothing special U have to do and there is NO that "mesh" option but bake is available only AFTER U save the scene and than U hit bake and everything works superb! Only still wondering how to see the results for drop and bubble cause it turns the whole fluid from SOLID to WIRE in the viewport. Also the control panel looks a lot different than in the previous versions I tried or from the image U sent here. Will try some more tests soon and give U some feedback with screens- THX for Your support buddy! $\endgroup$ – Jan Matys Sep 22 '18 at 15:44
  • $\begingroup$ I also tried Blender 2.8 with Manta and there it is precisely like U wrote here but no matter what Ive got only an outline result in viewport no matter there is a SOLID draw type choosen in Object tab - why? $\endgroup$ – Jan Matys Sep 22 '18 at 16:30
  • $\begingroup$ Could U please send here some working .blend file? $\endgroup$ – Jan Matys Sep 22 '18 at 16:43
  • $\begingroup$ @JanMatys in the mantaflow build there are two fluid options, "Fluid (Elbeem)" which is the old one and "Fluid (Mantaflow)" are you enabling the right one? Here is a basic sim saved from a mantaflow build. $\endgroup$ – sambler Sep 23 '18 at 5:53
  • $\begingroup$ Tried Yo scene with 2.8 (Manta only!) and the sim works well! Could some of U please point me on a download link of 2.79 Manta with working particles? $\endgroup$ – Jan Matys Sep 23 '18 at 18:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.