Preview area of blender video editor is always white (blank) no matter what the picture or the video is. enter image description here

After a little research, I found out it's due to my old OpenGL: enter image description here

I can't afford to buy a good graphics card and I really need this video editor. My graphics card was able to run many video editing software such as sony vegas...etc. It was also able to run 3D max and Cinema 4D. The only withdraw is that the rendering process is slow. So I feel like my card is able to run blender's video editor and it's just a bug but I don't know how to tweak or fix it.

I'd like answers with creative ideas. I wouldn't like the answer to be like You can't.

  • 1
    Try older Blender versions – WhatAMesh Sep 21 at 22:52
  • I used to run 2.6x with a 64MB Geforce 4 MX, set your monitor bit depth to 16bit or try a lower the resolution. Maybe make blenders window smaller instead of full screen. – sambler Sep 22 at 5:26
  • @WhatAMesh I tried four different versions but still have the same issue. The versions are: 2.76 & 2.67 & 2.59 & 2.48 – user2824371 Sep 23 at 1:12
  • 2
    Turn down the render resolution i.e 25%. Lower the proxy render setting (video view properties). Lower the memory usage of the machine by other apps so it is available to Blender. – rob Sep 27 at 8:01
  • 1
    I used to run 2.48 on very very old hardware and like you say, the only issue was how slow it was. This should work. – rob Sep 27 at 8:02
up vote 3 down vote accepted
+50

Not having your exact hardware, it is really difficult to give an exact answer, or even good suggestions. You didn't even describe your pc specs or your card model, drivers version. It could help.

But I think you could, as a last resort, try a software opengl emulation. It won't be performant, it won't be fast and it could have (other) glitches, but at least you could try.

How? In simple terms, usually blender relies on the (usually much powerful) opengl hardware implementation but there are software implementation that are run by your cpu, and they could support better opengl levels, hopefully better than your gpu or driver.

The most used, I think is Mesa (https://mesa3d.org/) and you should build (compile) it to obtain a dll. But you can also find some .dll pre-built around... just be careful about the source you're relying on!

Here is a developer's thread that explains roughly how to do this (note the link suggested is now dead!):

https://developer.blender.org/T43077

Download opengl32.dll from http://download.blender.org/ftp/incoming/softwaregl/ and put it into the same folder as the blender.exe. This will switch blender to fully software opengl mode, avoiding possible issues with driver/configuration

I found a steam thread that has working links, apparently

for 32bit http://download.blender.org/ftp/sergey/softwaregl/win32/opengl32.dll and for 64 http://download.blender.org/ftp/sergey/softwaregl/win64/opengl32.dll once downloaded just put in the directory of blender

https://steamcommunity.com/app/365670/discussions/0/598198356178829559/

See this thread also

https://www.opengl.org/discussion_boards/showthread.php/138029-OpenGL32-dll

I used this approach once (on linux, on thinkpad R60 with a crappy intel card) and it kinda worked, although the most complex functions in blender had issues, but I used this way until I had a new pc, with a much better card, to use the (at the time) newest blender versions... So, you have to try, and maybe report here your findings, to help others!

Good luck!

  • Download opengl32.dll from and put it into the same folder as the blender.exe. This works for me, thanks a lot. – user2824371 Sep 30 at 0:05

Well... Update your video drivers, disable everything that you can in the User Preferences (ctrl+alt+u) especially anisotropic filtering, multisampling, and make sure you try GLSL image drawing mode.

enter image description here

That's about it. If it works it works if it doesn't, then it doesn't.

You cannot work with video if you cannot afford good hardware - no amount of wishing is going to change that.

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.