1
$\begingroup$

I've just built myself a new machine because rendering times on my laptop were prohibitive. It's an i7900 10 core processor, 32GB RAM and two Quadro P4 graphics cards with 8GB memory each. The cards are set up to run together under NVIDIA's SLI configuration and Blender recognises them both for GPU rendering.

Whilst rendering times have improved dramatically, Blender rarely uses more than 10% of the CPU and no more than 50% (rarely) of one graphics card. The other one just sits there gathering dust with the odd 2% contribution according to the system monitor.

My question is: why doesn't Blender use more of the kit? It seems to me I should be getting blazing performance with the extra capacity but it never breaks sweat.

Incidentally, I have an animated sequence of 1300 identical spheres falling under gravity and the viewport grinds to a halt whilst CPU does almost nothing - it doesn't update between frames and Blender doesn't respond seemingly due to working hard on calcs. I don't get it.

Am i missing something?

Thanks

Really slow animation

Animation render

Screen shots as suggested.

$\endgroup$
  • 1
    $\begingroup$ What is your tilesize? Have you tried more complicated scenes (benchmarks)? Can you provide screenshots of your settings, so we can verify what you actually selected? Just putting it out of the way: Blender is veery likely not the issue. $\endgroup$ – WhatAMesh Sep 21 '18 at 11:58
  • $\begingroup$ Hi WhatAMesh, thanks for your interest. My tile size is 240x180 but i have the autotile size add-in enabled, is this unwise? Screenshots above and i'll run some benchmarks when i get some breathing space. Appreciate your help. $\endgroup$ – Stephen Samuels Sep 21 '18 at 16:39
  • 1
    $\begingroup$ Try Houdini for your simulations, it will use all your threads and even openCL of your Quadros for simulating. You paid for HW, paying for SW makes sense here to use it fully. Blender cannot match this, it's single core mostly with no GPU support.. As for Cycles rendering that usually does not work with SLI and you need to have 2 gpus as compute devices. You should get 100% utilization from both gpus when rendering, the CPU is just used to fetch data to them, so it's normal to be low. In Blender 2.8 will be option of hybrid rendering - cpu and gpu together. $\endgroup$ – Jaroslav Jerryno Novotny Sep 21 '18 at 17:02
  • $\begingroup$ Also since you have Quadros you can use the gpus same as Tesla cards bypassing Windows Display Driver Model to gain the same performance as under Linux: blog.thepixelary.com/post/167616662857/… $\endgroup$ – Jaroslav Jerryno Novotny Sep 22 '18 at 14:46
  • $\begingroup$ Thanks for the comments and advice. My main issue at the moment is painfully slow animations/simulations but will ask another question on that one. Appreciate your help. $\endgroup$ – Stephen Samuels Sep 25 '18 at 7:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.