I got the following curve enter image description here

But in edit mode it is ridiculous messy. enter image description here It looks it's really small, but if i hit Ctrl+A (Apply) > Scale nothing will change.

Why does my Curve not apply the scale?


As Robin Betts says, Apply Scale does work for curves as well.

If the Normals length are bothering you, you can change the display in the N panel (3D properties) > Curve Display > Normal Size

enter image description here

  • If you scale anything in Object Mode in Blender, (Curve, Mesh, or Text), the scale is changed in its Transformation Matrix. The stored coordinates of the object's vertices/control points are not modified, they are transformed by the matrix before inclusion in the scene.

  • If you scale anything in Edit Mode, you are scaling the object's elements. Their stored coordinates are modified, and the Transformation Matrix of the object is unchanged.

  • Applying a scale (CtrlA) does not change the size of an object - it 'bakes' the effect of the Transformation Matrix into the object elements' coordinates, scaling them, while returning the scale component of the object's Transformation Matrix to 1 in all axes. making it as if you had performed all your scaling in Edit Mode in the first place. You can see the effect in the Transform >Scale panel of the Properties Region of your 3D View.

You should be able to scale your text (S) about your selected pivot point, in Edit Mode, or Object Mode, whatever form it is in.

The 'Mess' you can see on entering Edit Mode is not part of your curve. It is simply the display of the curve's normals. When in Edit Mode of a curve, that can be disabled/adjusted in the 'Curve Display' panel of the Properties Region you have open on the right of your 3D View.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.