1
$\begingroup$

I'm struggling to get crisp and smooth lines with Freestyle (in Cycles). I can clearly see jagged edges, the sort you'd expect from the lack of antialiasing. Is there a way to apply antialiasing to Freestyle renders? Can I do anything else to get presentable images that I can use? I love what I can do with Freestyle, but I have yet to get results that I'd feel OK with publishing. Example below. Thanks!

enter image description here

$\endgroup$

closed as unclear what you're asking by batFINGER, Duarte Farrajota Ramos May 10 at 15:54

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    $\begingroup$ Do you have any kind of dashed lines enabled? Could we see your line settings? $\endgroup$ – gandalf3 Sep 14 '18 at 5:19
  • $\begingroup$ Increase resolution and increase line width. Anti-Aliasing is basically rendering at increased resolution and downsample later $\endgroup$ – miceterminator Sep 14 '18 at 8:02
  • $\begingroup$ Thank you for the comments. I do not have dashed lines enabled. I'm happy to upload a screenshot of my line settings, but there are many tabs for the line styles (Thickness, Alpha, Color, Geometry, and Texture, I believe), not to mention different areas in which to change Freestyle settings. Just wondering which settings in particular would be relevant here? $\endgroup$ – Alex Sep 18 '18 at 1:11
  • $\begingroup$ I did experiment with many different settings, including the resolution and line thickness. Increasing the resolution seemed to make things worse, in part because the image becomes larger and so I have to scale it down for publishing. I avoid scaling raster images, because inevitably my graphics become fuzzy, though here, the issue is that my lines become scraggly. I did try increasing line thickness along with the image resolution, and while the lines turned out less scraggly, they were far too thick for the eye. I've seen perfect Freestyle lines that are very thin, so I know it can be done.. $\endgroup$ – Alex Sep 18 '18 at 1:18
  • $\begingroup$ @Alex Hm, probably the easiest way would be if you could upload a .blend (e.g. with just a cube) for us to examine. $\endgroup$ – gandalf3 Sep 19 '18 at 3:42
0
$\begingroup$

You've probably solved the problem by now but I just ran into this problem and found an easy solution: increase the Render Samples to 30.

I had the same problem when Cycles only computed 1 sample. At 2 samples, it was much better and so on.

I hope that helps someone.

$\endgroup$

Not the answer you're looking for? Browse other questions tagged or ask your own question.