2
$\begingroup$

I am trying to make a game in BGE, but when I play, the models are all bright white.

I read on a forum that you have to change the shading to GLSL, but it stayed white.

.blend file:

$\endgroup$
1
$\begingroup$

I can guess only, but maybe the 3D view is in solid shading mode. Try to switch to textured mode, you should see textures then.

So, change the mode from

Solid Shading Mode

which results in:

Ingame View of Solid Mode

to:

Textured Shading Mode

which results in:

Ingame View of Textured Mode

EDIT: After seeing your file, I think the behavior you described comes from another few problems:

  • The ground material's Emit setting is set to 2, which makes the material emissive and therefore it's not interacting with lamps.
  • There are no lamps in the scene.
  • The texture on the ground plane is just plain white, you can just use the material color for that. The player object has that texture too.
$\endgroup$
  • $\begingroup$ I added my file to the post, maybe you could give instructions with screenshots, it would be very well appreciated. $\endgroup$ – romoon Sep 14 '18 at 20:17
  • $\begingroup$ @Angyeet I've updated my answer, I hope it's better now $\endgroup$ – timodriaan Sep 15 '18 at 12:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.