0
$\begingroup$

I'm using mp4 video projected onto a 2d plane in the 3d viewer, but cant get them to animate or scrub through timeline in texture or material mode unless I open up an extra window with cycles render on. Is there a way to simply allow it to animate without having to open up an extra render preview window?

PS: Thanks for the support on my last questions. you Blender Gurus are the best!

$\endgroup$
0
$\begingroup$

If you use video as reference, best way to do this - using image empty.

Image empty always shows current frame; over methods, that i'm tried gives +-1 frame offset. To add image empty press Shift+A -> Empty -> Image

$\endgroup$
  • $\begingroup$ Allow me to clarify: The clip (actually a mov, not mp4) with alpha is embedded into a plane object and is to be used "not as a reference", but as an actual "active element" inside the scene, that interacts with 3D elements inside. my problem is, that the animation frames in the video clip do not refresh when the time line is scrubbed/advanced until I set the scene to render. does not work in either texture, or material mode unless I open up an additional viewport window and view it as render. upon which, all windows will refresh. $\endgroup$ – Gustavo Guzman Sep 12 '18 at 14:10
  • $\begingroup$ I don't know methods, that solves this problem, use yours. And vote my feature request: blender.community/c/rightclickselect/Z0bbbc $\endgroup$ – Crantisz Sep 12 '18 at 14:22
0
$\begingroup$

SOLVED

Simply go to Add, on the bottom on 3d panel, then Mesh > Image as Plane and check box Animate Image Sequence on the Operator Presets to the left. It will then animate in Material Mode.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.