3
$\begingroup$

I am running a very simple simulation. However, something weird happens at the beginning of the simulations. It looks like the chair is pulling the monitor towards itself. Or the monitor is attracted to the chair. Why is that?

enter image description here

$\endgroup$
  • 1
    $\begingroup$ You baked the animation. If you go in the Properties panel > Scene > Rigid Body Cache, you can click on Free Bake and it will reset the animation. It doesn't explain why your initial animation worked this way though. $\endgroup$ – moonboots Sep 11 '18 at 6:58
  • $\begingroup$ Did you try with the monitor itself, without the chair, does it happen anyway? $\endgroup$ – m.ardito Sep 11 '18 at 11:00
  • $\begingroup$ Where is the Origin point for both objects? I have seen the same result when the origin/centre point is not at the logical centre of the mesh. $\endgroup$ – rob Sep 11 '18 at 13:59
  • $\begingroup$ @moonboots Sorry I forgot to free the cache and then upload the .blend file. But this happens almost every time regardless. $\endgroup$ – Amir Sep 11 '18 at 15:11
  • $\begingroup$ I don't know a lot about Physics and bake, but it looks like your file is still a baked version, if you click on Free Bake you can manipulate your objects and they fall normally $\endgroup$ – moonboots Sep 11 '18 at 15:21
1
$\begingroup$

I tried your file, I found that just following what @moonboots said above in comments should work, but sometimes... it doesn't, and it's weird!

Here is when I tried to "free" rigid body cache, and also to "free all bakes": it didn't work.

enter image description here

Then I tried a trick: apply scale, and it worked, the "screen" mesh fell in a more natural way, but after reaching the floor, it fell downwards...

enter image description here

So, I tried to apply also rotation, and in this way it worked how you probably expected:

enter image description here

Applying transforms (particularly scale and rotation) is always recommended when you simulate physics in blender, and most of the times it solves even weird issues like this one.

$\endgroup$
  • $\begingroup$ It's very weird why this keeps happening. This makes the physics simulation very unreliable :( $\endgroup$ – Amir Sep 11 '18 at 15:13
-1
$\begingroup$

Such phenomena have to do with gravity (it is ca. 9.81 m/s^2) and mass. Check if the screen is heavier or, for one of the monitor's legs, gravity is more than 9.81 m/s^2. If either is true, give all parts of the monitor the same mass and the same gravity and see what happens.

$\endgroup$
  • $\begingroup$ sorry, what you mean by a mesh individual gravity setting? I think there's only one setting for the gravity force, in the scene settings... and that's share by all scene's objects... $\endgroup$ – m.ardito Sep 11 '18 at 11:03
  • $\begingroup$ I didn't speculate, I checked, and I found only the scene setting... could you please add details, it could be interesting. $\endgroup$ – m.ardito Sep 11 '18 at 13:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.