0
$\begingroup$

As I am fairly new to Blender, I made a donut (surprisingly). It has sprinkles as particles. Today I tried to make an animation of it with a moving camera, but there are three frames (3, 14 and another one) where the particles change position see here. Even when I render those frames individually, it still happens.

Since I have no idea what the problem could be here, I don't know if I need to list any settings. If that is helpful, please let me know. Any help is appreciated!

$\endgroup$
  • $\begingroup$ Please share your blend file so that I can take a look at it? You can do this by uploading the blend file on this site - blend-exchange.giantcowfilms.com and copy + pasting the generated url here. $\endgroup$ – Teja Sep 9 '18 at 18:41
  • $\begingroup$ Sure, I've included the link in the post. $\endgroup$ – user62173 Sep 9 '18 at 20:32
1
$\begingroup$

The problem is with the 'Post processing' settings under render panel.You need to uncheck the sequencer.

enter image description here

Because when the sequencer is checked, it takes into account any videos or image strips already present in the video editor. In your case, you do have a video - most likely a previously rendered video.In such a case, whenever you hit render, instead of rendering the frame again, it simply picks the frame in that video and shows you as render.

You can verify if you have any videos by going into Video Sequence Editor as shown.

enter image description here

enter image description here

Instead of unchecking the sequencer in render settings. You can also delete this video strip to render properly.You can do this by right clicking on it and pressing delete button. You will get an option to 'erase strips'. Click it.

enter image description here

One small suggestion. When you are uploading a blend file here or sharing with someone else please click on 'Pack all into .blend' (as shown below) and save the file before sharing.

enter image description here

This way the textures and files you are using will also be shared in the blend file. In the file you shared, the video and brick textures were not included. This led to delay in figuring out, what the actual problem is. Hope this helps, if not share the blend file again, this time with external data packed.

$\endgroup$
  • $\begingroup$ Thanks for the answer! I will try it out as soon as I get the opportunity. The sequencer being the problem makes a lot of sense, as I've done some separate renders at certain points on the timeline. As for the blend file, I wasn't aware of the option to export it in Blender and just uploaded the file itself instead. I definitely will keep it in mind in the future. Again many thanks for the help and effort! $\endgroup$ – user62173 Sep 10 '18 at 19:08
  • $\begingroup$ Glad I could help :) $\endgroup$ – Teja Sep 10 '18 at 19:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.