I am using Arch Linux and am trying to use GPU Rendering in Blender. In the Arch Linux Wiki from Blender I read that I need either the AMDGPU-PRO or the opencl-amd package. So I installed the opencl-amd package and clinfo shows one platform with OpenCL 1.2.

But when I start Blender and change the Renderer to Cycles Render, it crashes. Showing the error amdgpu_device_initialize: amdgpu_query_info(ACCEL_WORKING) failed (-9) Segmentation fault (core dumped)

It is also crashing when I go to Settings > System with the same error message.

Blender Crash Log: https://pastebin.com/uaGcZAZ2

I have a RX 580 and using open-source amdgpu drivers on Arch linux.

  • I've encountered the same problem since an update at the beginning of the week. I'm unsure if the amdgpu_query_info() function is part of the blender source or if it's in the AMD opencl libraries that get ripped out of the proprietary driver and re-packaged as opencl-amd. AMD Radeon Pro WX-5100 was working a treat until a few days ago :( Mowley :) – Mowley Chris Sep 13 at 20:35
  • I've been (unsuccessfully) trying to find where this is being tracked, assuming its not purely a problem with the opencl-amd package. I haven't tried installing the *-pro drivers, but if it's reproducible there I imagine it's time for a report to amd – gandalf3 Sep 13 at 23:25

Having done some more poking around I have specifically pinned it down to only the libdrm update, downgrading to libdrm 2.4.93-1 is currently a functioning workaround.

https://bugs.archlinux.org/task/60061

I've also had this error since opencl-amd 18.30.641594 and libdrm 2.4.94. Rolling back to opencl-amd 18.30.633530 and libdrm 2.4.93 — as suggested in the comments on the opencl‑amd package — seems to work for the time being.

  • The Downgrading fixed the crashing when I select Radeon ProRender. But now I get a CoreError when I try to render a scene. Error – Sakkaku Sep 14 at 7:36
  • @Sakkaku I've not used Radon ProRender; is it possible that is a ProRender specific issue? Does GPU rendering with Cycles work? – gandalf3 Sep 14 at 8:07
  • It seems to be a problem from ProRender. GPU Rendering with Cycles works now in Blender. – Sakkaku Sep 14 at 12:48

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.