2
$\begingroup$

I have a quite simple rendering in Cycles, containing some droplets with a standard glass material – only glass node, connected to surface of material node.

The problem is, the glass increases the noise enormously. First Picture with glass:

enter image description here

Second picture for comparison with plain white diffuse material instead of glass:

enter image description here

This is just an extremly simple scene, and it's just rendered with 32 samples for testing purposes.

Is there a way to reduce the noise added by glass material? Please keep in mind, this is not about the noise in glass itself, but about added noise everywhere else.

$\endgroup$
  • 1
    $\begingroup$ Render tab -> Sampling -> Clam Direct to 1 and Render Layer tab -> De noising tick (mark on). This 2 setting can give good result $\endgroup$ – atek Sep 7 '18 at 14:34
2
$\begingroup$

Glass unlike diffuse materials bounces a lot of light, hence the noise. Low number of samples is the reason why the noise occurs. Denoising feature sometimes gives artifacts, especially on reflective surfaces such as metallic/glass/mirror. The best option would be to increase samples and remember that tweaking Denoising might be needed so I highly recommend doing it on another pass (Passes setting in Scene).

I wouldn't recommend clamping direct light because this way you're losing a lot of information and details on glass itself. Direct bouncing of light sometimes and denoising it can be painful, but I'm pretty sure that on higher samples (for example three digits) there is little or no noise.

$\endgroup$
2
$\begingroup$

Short version: glass shader is more complicated and needs more calculations to obtain a nice result. So either you set samples to higher values, either you use some trickeries in the shader or in the rendering settings in order to reduce the complexity (but at the cost of accuracy).

I invite you to read the Blender Manual about Glass BSDF, which explains this more precisely as well as giving you ways to reduce noise.

$\endgroup$
1
$\begingroup$

Try setting your samples on rendered to 256. It will probably look a lot better. You can use denoising as well - but yes, it could create artifacts.

Other thing - change your environment texture (whatever you are using). Could be a noisy thing, make it a smooth HDRI image.

$\endgroup$
  • $\begingroup$ Sure, I could increase the samples, but that's not the point. I have a far more complex animation, and with samples on 1024 it's still a bit grainy, but needs 45 mins per frame. This takes mostly so long because of some glass. I don't use an environment texture, just some lamps and plain white diffuse environment. $\endgroup$ – Grimm Sep 7 '18 at 15:38
  • $\begingroup$ try changing your environment then to a background image - OR - use an emission shader, not a diffuse shader. A diffuse shader by it's nature "is" grainy. $\endgroup$ – user6262902 Sep 7 '18 at 16:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.