0
$\begingroup$

I'm using blender 2.79b to edit a video. I'm not using it for 3d modeling at all. I edited the video in the VSE and everything plays fine from inside of blender. I then render the video to a file. I've tried every combination of audio codecs with the MPEG-4 container and H.264 video codec but every time the audio is either not present or is garbled when playing in Windows Media Player. Every case except for using Vorbis as the audio codec is garbled or not present when using VLC. I tried uploading the version using Vorbis to You Tube and the You Tube playback was garbled.

enter image description here

My searching and experimentation has reached its limits so I'm hoping someone can help me. Thank you!

$\endgroup$
  • $\begingroup$ I have also tried changing the bitrate and the sample rate but these still did not solve the issue. $\endgroup$ – James Sep 7 '18 at 4:12
  • $\begingroup$ If you try playing the rendered video inside blender (i.e. adding it as a strip) does the audio play fine? $\endgroup$ – qwazix Sep 7 '18 at 6:37
  • $\begingroup$ Have you tried with another sound source? Does the sound source itself play fine in media players? $\endgroup$ – m.ardito Sep 7 '18 at 6:57
  • $\begingroup$ @qwazix It plays fine inside of blender but once I render the output it's garbled/noisy. $\endgroup$ – James Jan 5 at 19:37
  • $\begingroup$ @m.ardito Yes I've tried other files. All of the files play fine on their own. $\endgroup$ – James Jan 5 at 19:37
1
$\begingroup$

I finally got good output by converting the file I was trying to use to a wave file and using that in Blender. The weird thing is the video in Blender would then be choppy when previewing it, but the rendered output was ok. If anyone knows why this happens, or a way where files other than wave can be used, please let us know.

$\endgroup$
  • $\begingroup$ Wav files are quite old and minimally compressed so are generally most broadly supported. Why it plays choppy might have to do with the minimal compression? There are user preferences to alter so that audio playback is better. $\endgroup$ – 3pointedit Jan 7 at 9:47
  • $\begingroup$ Try going to user prefs>System>Sound>Audio Device> choose SDL $\endgroup$ – 3pointedit Jan 7 at 9:49
0
$\begingroup$

First try removing elements of the audio strips to find the problem source.

Also just use AAC audio codec for h264, as that should work ok.

Also you could do an audio only mixdown to flac, then re-import that into Blender as the master audio.

Use the Audio button nexct to the Animation button on the Project render properties panel.

mixdown button

Then find that file and replace the other clips in your timeline (you can just turn them off if you need to re-edit later)

$\endgroup$
  • $\begingroup$ Neither of those suggestions worked either. :( $\endgroup$ – James Jan 5 at 19:36
  • $\begingroup$ Even the mixed down flac file output is distorted. $\endgroup$ – James Jan 5 at 19:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.