2
$\begingroup$

This has been asked before but I can't find the solution now. The solution was something about going into blender render, setting the bake type to vertex colors and then just baking but I'm just getting pure white bake. Obviously I'm missing some steps... or something. I do most of my work in cycles so I think the issue could be something to do with the nodes. Do the nodes or materials need to be set up in certain way?

Baking vertex colors has been working just fine before. I just did this a couple of days ago but something has now changed and I can't get any my vertex colors to bake anymore. I just get white.

$\endgroup$
1
$\begingroup$

Setup material like this, Using emission node makes it fast:

enter image description here

You can get vertex color data here:

enter image description here

In bake options chose "Emit"

enter image description here

$\endgroup$
  • $\begingroup$ I just get white bake with this. $\endgroup$ – Life Sep 5 '18 at 19:56
  • $\begingroup$ show your setup $\endgroup$ – Crantisz Sep 5 '18 at 19:58
  • $\begingroup$ If I make new blend that thing you showed works. But on my blend file it doesn't. $\endgroup$ – Life Sep 5 '18 at 20:02
  • $\begingroup$ Make a screenshot and post it in question body $\endgroup$ – Crantisz Sep 5 '18 at 20:03
  • $\begingroup$ Oh my god I'm such a total idiot! I had my image editor set to show alpha and not the diffuse channels (those little icons next to the pivot options in image editor). I was looking at the alpha channel instead of the rgb channels... $\endgroup$ – Life Sep 5 '18 at 20:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.